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Titolo
ODMAD Sync Error: "DistinguishedName is required to add a new object"
Descrizione
Source objects are not syncing to the target environment. Workflow logs show an error "DistinguishedName is required to add a new object" or
Write: distinguishedName is required to add a new object.
Causa
1. This error typically occurs when the DN mapping is missing from the template for the particular workflow. 2. If the DistinguishedName mapping exists then there is an issue with the Condition field value. usually a syntax or formatting issue. If this was changed to add a conditon of Action = "Create" Then "Create" MUST be in lower case.
Risoluzione
Resolution 1 From Directory Sync dashboard
Go to Templates and edit your template
Go to 'Mappings' tab
Add the mapping for DN
Save Template
Got to ODM AD Environments
Edit source and target environments to run 'Reconcile on Next Read'
Save
Run the workflow
Resolution 2
Edit the DistingishedName (DN) attribute mapping Go to Condition field and change the value from Action = "Create" to Action = "create" Save Run workflow
Informazioni aggiuntive
The issue is applicable to any attributes, that utilize Advanced Mapping. The word "create" must be all lowercase.
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Data di creazione: 10/1/2021 Ultimo aggiornamento: 12/2/2025
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