Al momento non è possibile inviare moduli sul sito di supporto per pianificare la manutenzione. Se necessiti di assistenza immediata, contatta il supporto tecnico. Ci scusiamo per il disagio.
Questo articolo ti è servito per risolvere il problema?
Seleziona valutazione
Titolo
Public Folder MAgE Error: "Violation of PRIMARY KEY constraint 'PK_PF_MATCH'. Cannot insert duplicate key in object 'dbo.PF_MATCH'"
Descrizione
When running Public Folder MAgE through PowerShell the following error occurs similar to or exactly the following:
PublicFolder job already exists in the project.
Collection with name 'Public Folder Collection (10-239-34-32)' already exists in PublicFolder job.
"Violation of PRIMARY
KEY constraint 'PK_PF_MATCH'. Cannot insert duplicate key in object 'dbo.PF_MATCH'. The duplicate key value is
(28366)."
Causa
This issue has come up when Multiple Source Exchange Organizations with Public Folders are to be migrated and the PF MAgE PowerShell Script had already ran successfully once against one of the Organizations.
Risoluzione
WORKAROUND
Public Folder MAgE does not support multiple source environments, which is why the PublicFolder Job already exists in the project, with SQL unable to insert duplicate information into the database.
If required to migrate Multiple Source Environments with Public Folder MAgE into the same Target, deploy additional projects. 1 Project per Source Public Folder Environment you wish to migrate.
STATUS
Enhancement Request MMEX-10525 has been submitted to Development for consideration in a future release of Quest Migration Manager for Exchange
ID difetto
MMEX-10525
Feedback inviato
Questo articolo ti è servito per risolvere il problema?
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Contenuti consigliati
Prodotto/i:
Argomento/i:
Configuration
Cronologia articoli:
Data di creazione: 9/28/2020 Ultimo aggiornamento: 5/7/2023
Thank you for your feedback for Topic Request
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Questo è il portale del supporto
Puoi trovare aiuto e supporto online per Quest *prodotto* sul sito di supporto di un affiliato. Fai clic su Continua per essere reindirizzato ai contenuti e all'assistenza corretti per *prodotto*.
Search All Knowledge Base
Internet Explorer 8, 9 e 10 non sono più supportati
Il portale Quest Software non supporta più Internet Explorer 8, 9, e 10. Si consiglia di aggiornare il browser all'ultima versione di Internet Explorer o Chrome.