Replication might get stuck running and unable to stop or disable the replication.
原因
lost the log on as batch job permissions on the account running the replication.
解决办法
Open the RMAD management console and run the following scripts:
[QuestSoftware.RecoveryManager.AD.PowerShell.RmadBootstrapper]::Init() [QuestSoftware.RecoveryManager.AD.Synchronization.Core.Session.ReplicationSessionProvider]::GetSessions() This command returns all replication sessions. If you have any sessions that are stuck in "Running" state, you can update them with the following script: [QuestSoftware.RecoveryManager.AD.Synchronization.Core.Session.ReplicationSessionProvider]::GetSessions() |? { $_.Result -eq "Running" } |% { $_.UpdateResult("Success") } The same can be done for session items. Check them first for any "Running" session items: [QuestSoftware.RecoveryManager.AD.Synchronization.Core.Session.ReplicationSessionProvider]::GetSessions() |% { $_.GetItems() } And then update them, if you have any in "Running" state: [QuestSoftware.RecoveryManager.AD.Synchronization.Core.Session.ReplicationSessionProvider]::GetSessions() |% { $_.GetItems() } |? { $_.Result -eq "Running" } |% { $_.UpdateResult("Success") }