Another object with the same Name or UserPrincipalName already exists; Map the target account before migrating.
说明
If you have two accounts in the source with the same Name, but different UPNs, you will be able to discover them, however during the migration, you are going to encounter the error below: Another object with the same Name or UserPrincipalName already exists; Map the target account before migrating.
原因
There is already an account in the target environment with the same Name. There is not yet a built-in feature to create another account in the target tenant with the same displayname but different UPN with On Demand Migration.
解决办法
The account need to be manually created in the target, and then map the account from file, using the UserPrincipalName or the ObjectId.
其他信息
This feature is on our roadmap and will be implemented in the future.