How to find and add Office 365 MX record to your internal DNS Domain zone
说明
For the KACE SMA to send and received emails using Office 365 a valid MX record is necessary.
The MX record can be found on your DNS, also it can be verified if an MX record is present by following the instructions below
Additionally, a test can be performed on the Appliance under Settings | Support | Diagnostic Utilities | mx lookup, on the text box input the domain and click on Run Now
Example:The answer Section will show where the MX record is pointing to.
原因
When a MX record is missing or pointing to the incorrect address; emails won’t be able to route properly
解决办法
Locate the MX Record information in Office365 by going to Microsoft 365 Admin Center
In the admin center, go to the Settings > Domains.
On the Domains page, Click on the domain and then choose DNS Records.
At the next screen, click on DNS Record, the screen should be similar to the one below, there will be the value needed to add to the local DNS server
On your DNS Server
Find domain under Forward Lookup Zones, right click, and select “New Mail Exchanger (MX)”
In the new pop-up window fill the information with gather from Office365 admin panel as shown in the example below.
Important note: ***In case you have more Domain zones, Add the MX record also to those zones. ***