Users assigned with either the AlarmAdmin role or the Administrator role in Foglight cannot access alarm templates.
A message in red "Accessing alarm-template requires Administrator role" appears in the panel UI.
A message similar to the following appears in the FMS log:
ERROR [http-exec-3] org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/api].[Forge REST API] -
Servlet.service() for servlet [Forge REST API] in context with path [/api] threw exception [java.lang.NullPointerException] with root cause
ERROR [http-exec-4] com.quest.nitro.service.rule.service.AlarmTemplateService -
An unexpected error occurred which may cause undesired behavior.
You may want to contact customer support if you see this error again:
fail to get alarm template group object using rule nameStaging Template
or an error like the following appears in the FMS log
ERROR [http-exec-5] com.quest.forge.rest.provider.UncaughtExceptionMapper - Internal Server Error
java.lang.InternalError: Can't find domain [Database.Snowflake]
CAUSE 1
An Alarm Template topology object in the system that isn't associated with a Topology Domain object.
CAUSE 2
Older version of cartridges are activated in the environment and the ones matching the current Foglight version are deactivated.
CAUSE 3
Corruption in the cartridge noted in the error message
WORKAROUND
First delete the incomplete alarm template that is specified in the error message of the FMS log using the following groovy script. In the example below the Template name is "Staging Template"
def output = new StringBuilder() def alarmTemplateObjs = #! AlarmTemplate where name = 'Staging Template' #.topologyObjects output << "Found topology object: " << alarmTemplateObjs << '\n' try { server.TopologyService.deleteObjects(alarmTemplateObjs as Set) output << "Alarm Template deleted.\n" } catch (e) { output << "Failed to delete Alarm Template: " << e } return output.toString()
The groovy script can be run from Administration | Tooling | Script Console as described in KB 4309796
If after making this change, users do not have access to add targets for any of the database cartridge domains
STATUS
Enhancement ID FOG-3895 was logged to prevent these errors from surfacing, and to possibly automatically cleanup invalid configuration. This has been added to the 6.3 and higher releases of the Foglight Management Server.
Enable the newest compatible version of each cartridge installed in the FMS
Reset the cartridge named in the FMS error message using the Cartridge Inventory dashboard