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Cannot connect to the database after the computer disk was replaced
Description
Cannot connect to the database after the computer disk was replaced. It is possible to connect to the database with other tools and from other computers. To reinstall Toad or catalog the database manually does not help. The error Toad shows is "ERROR - no error information available". The error in the db2diag.log is :
"FUNCTION: DB2 Common, Cryptography, cryptDynamicLoadGSKitCrypto, probe:998 MESSAGE : ECF=0x9000002F=-1879048145=ECF_FILE_DEVICE_UNAVAILABLE The device is unavailable or uncapable of serving the request DATA #1 : unsigned integer, 4 bytes" The old disk label was E:. Now E is the CD driver.
Cause
Toad reads the Environment variable PATH to look for the client and there was a reference to the old E drive there
Resolution
RESOLUTION
The Environment variable PATH had one reference to the old E:\ drive. After removing this reference , it was possible to connect to the database again.
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Recommended Content
Product(s):
Toad for DB2
Topic(s):
Technical Solutions
Article History:
Created on: 5/27/2014 Last Update on: 5/7/2023
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Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
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