Cannot connect to Analysis Services instance from Spotlight on SQL Server Enterprise. SQL Server Management Tools have already been installed on the Diagnostic Server.
Similar error shows:
Collection 'SSAS - Cache' failed : WMI query 'Win32_PerfRawData_MSSQLServerOLAPService_MSAS2008Cache' failed : Invalid class. [0x80041010]
CAUSE 1
The “Quest Diagnostic Server” service was running under the local system account.
CAUSE 2
Connecting to a named instance and not using the full named instance name in Spotlight connection.
WORKAROUND 1
To allow the Diagnostic Server monitoring Analysis Services instances, run it under a domain account which will have granted rights to access the Analysis Services instance.
There is no way to specify credentials on connection level for SSAS-connections (Microsoft allows using only windows authentication when connecting to SSAS).
WORKAROUND 2
When creating a Spotlight connection to the Analysis Server named instance, be sure to specify as follows:
hostname\instancename
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