Troubleshooting failures with the VMware Plugin and hotadd mode
Appliance mode (hotadd) fails or configuration assistance is needed.
The following is shown in the statistics window while processing a VM:
Hot add is not supported for this disk, failing over to network mode...
The following can be found within the logs:
“output: --wn:Hot add is not supported for this disk, failing over to network mode...\n”
If the NetVault Proxy being used to process the source VM is on a VMFS 3 datastore it must be formatted with proper block size to be able to mount the largest virtual disk of the hot added VMs.
1MB block size – 256GB maximum file size
2MB block size – 512GB maximum file size
4MB block size – 1024GB maximum file size
8MB block size – 2048GB maximum file size
The Proxy being used to back up the VM must be a Virtual Machine on a host that is able to access the datastore where the source VM’s disks are stored.
Note If you are backing up multiple VM’s there will be more than one VMDK file mounted at a time so this also needs to be taken into account.
Further Known Issues:
Note: It is advised to add the maximum number of SCSI controllers (4) with a small 10MB thin partitioned disk on each controller.
Reconfigure attempt failed for VM "" Exception ("vim.fault.HostAccessRestrictedToManagementServer")
Troubleshooting for the above:
Test to see if the disk of the VM to be backed up can be manually hotadded to the proxy. See below:
Performing the following steps will help determine if the infrastructure is present to allow the Proxy to attach the disks of the VM to be processed in hotadd. It is advised to do this with a VM during off-peak hours as it requires a snapshot on the production server.
1. Create a snapshot on the VM to be processed by NetVault Backup
2. Within a vSphere client, attach the base disk from the VM in Step 1 to the Netvault Proxy.
3. If this task completes this means the infrastructure is present to allow the Proxy to hotadd the VMs base disk.
4. Detach the disk that was attached to the NetVault Proxy.
a. Edit the NetVault Proxy from Step 2
b. Highlight the attached disk.
c. Click Remove (DO NOT change the radio option)
d. Click Finish
Check all NetVault Proxies for old hotadded disks and release them manually.
Objective:
While using Virtual Appliance Mode, a VMDK is not removed from the NetVault Proxy.
Cause:
The VMware API call to remove the VMDK was not received or did not complete properly.
Solution:
Through vSphere, you should be able to right-click the NetVault Proxy VM and select edit settings. Look for the Hard disks attached to the VM. Normally the stuck disks will be listed at the bottom of hardware list.
You should also be able to identify the disks by the name and the datastore they are in under the disk file box (top right).
To remove them, select the disk by clicking on it and select remove at the top right. You will see the disk crossed out.
Under removal options choose “remove from virtual machine” DO NOT choose the option that deletes it from disk (the second option).
We add the disk as Independent Nonpersistent, so we do not need to worry about making changes in Windows or removing it from disk management.
After successfully removing the disk, you will need to remove the snapshot the VM being backed up is running on.
To do this, right-click the VM in vSphere and select snapshot then snapshot manager. A box will appear listing current snapshots. Select the snapshot named BKB_SNAP and select “delete” and confirm the removal. This will consolidate all the changes back into the base VMDK of the VM.
Disable automount on the backup proxy, as documented Below:
Objective:
Attempting to connect via RDP to a NetVault Proxy VM in VMware during a Virtual Appliance (hot-add) backup fails.
Cause
This occurs due to hung backup job utilizing that specific proxy, and that proxy is not configured to have automount disabled.
Solution:
In an Administrator Command Prompt run the following commands:
> diskpart
DISKPART> automount disable
DISKPART> automount scrub