Issue
Migrations fail to initialize on a worker.
This can occur for main mail file migrations or for archive migrations and will indicate that the AutoDiscover response for the main account or archive is not found.
Example Migration Log Detail:
@ 11:00:06 End of AutoDiscover and Profile Creation Log
11:00:06 AutoDiscover Response for Archive not found C:\Users\admin\AppData\Local\Binary Tree\Notes Migrator\user@DOMAINNAME.com-AutoDiscover-Archive.xml
@ 11:00:06 Entering CMTInitMAPI()
@ 11:00:06 MAPI Logon using profile: CMT Temp Migration Profile
@ 11:00:07 Log on Success
@ 11:00:07 Profile MsgStore Opened: migrationAccount@DOMAINNAME.onmicrosoft.com
@ 11:00:07 Using Mailbox Parameters for Target EntryID. Display Name: LastName, FirstName
! 11:00:07 Error: QueryInterface: 80004002
@ 11:00:07 Profile MsgStore Closed: migrationAccount@DOMAINNAME.onmicrosoft.com
! 11:00:07 Error: Failed to get Message Store
@ 11:00:07 Exiting MAPI Object Initalize
@ 11:00:07 Exiting ExchangeInitializeUser()
! 11:00:07 Error: Failed to initialize
Cause
If you receive this error for some or all migrations, check the migration workstations to confirm all Outlook/Office updates have been applied. Outlook Professional Plus 2013 SP1 which is part of Microsoft Office Professional Plus 2013 SP1 (32-bit only) (Microsoft update patch KB2878323 is the minimum required). We recommend applying all available updates for Outlook.
Solution
Utilize Microsoft Update to apply the current Outlook 2013 patch level or download the latest patch version for Office 2013 from the Microsoft download center.
Once the current Microsoft update is applied, reboot worker(s) and run migrations.
Alternative Solution
If applying the Microsoft Outlook (Office) patch does not resolve the failure to connect to the target mailbox then run a repair of the Office installation on the worker. This through Control Panel - Programs and Features.
Additionally remove any existing Outlook profiles through Control Panel - Mail (32 Bit) on the Profiles tab.
Run fixmapi.exe
Once that is completed restart the worker machine, open Outlook and enter the worker account credentials to verify that Outlook does connect to the migration account mailbox.
Confirm that the Outlook version number is the expected number from the patch applied (above) using File - Office Account - About Outlook.
Run a migration to validate.
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