Submitting forms on the support site are temporary unavailable for schedule maintenance. If you need immediate assistance please contact technical support. We apologize for the inconvenience.
System.DllNotFoundException Unable to load DLL 'C:\Users\rbobbitt\AppData\Local\Temp\tmp4422.tmp
Description
System.DllNotFoundException
Unable to load DLL 'C:\Users\rbobbitt\AppData\Local\Temp\tmp4422.tmp': Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
Stack Trace:
at Quest.Licensing.Validation.TempWrapper.getCurrentDay()
Cause
Conflict with directory accessed by Toad. Toad uses the temp folder and files for it's recovery feature. Normally,Anti-Virus software is blocking the access.'
Resolution
RESOLUTION #1: Check the following areas.
1) Turn off all virus protection software and launch TDP.
2) Go to the temp dir shown in the error stack. Have the user write a file to the temp dir. Do they have privileges?
3) Start TDP with Run as Admin privileges. What is the result?
4) Lower UAC and start TDP. What is the result?
5) Go to event viewer and look under the app and system area. Export all events for that day
6) Check if you have a second layer virus software like Sideline
Something from the Operating System is preventing the licensing DLL to load. Check with your internal support admin.
RESOLUTION #2: Install using the .msi file, which can be downloaded from the same page as the .exe file.
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Recommended Content
Product(s):
Toad for Oracle
Toad for SQL Server
Topic(s):
Installation
Article History:
Created on: 2/14/2017 Last Update on: 5/7/2023
Thank you for your feedback for Topic Request
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Welcome to Quest Support
You can find online support help for Quest *product* on an affiliate support site. Click continue to be directed to the correct support content and assistance for *product*.
Search All Articles
IE 8, 9, & 10 No longer supported
The Quest Software Portal no longer supports IE8, 9, & 10 and it is recommended to upgrade your browser to the latest version of Internet Explorer or Chrome.