Cannot reach the Foglight home page in a web browser.
Messages like "This site cannot be reached", "HOSTNAME refused to connect" and ERR_CONNECTION_REFUSED appear in the browser (Chrome).
CAUSE 1
Foglight service is not running
CAUSE 2
Network connection or firewall issues prevent accessing the server
CAUSE 3
Incorrect hostname or IP address is used in the web browser
RESOLUTION 1
Confirm that the Foglight Management Server application is running.
Windows
Foglight may be run as either a Windows Service or from the command line. Using the task manager to look for fms.exe is the quickest way to confirm that the FMS is running.
Linux/Unix
In Linux and Unix the following command can be used to find running foglight processes. In the results there should be several lines indicating that FMS is running.
ps -eaf | grep -i Foglight
A lack of Foglight application processes would look more like this.
When the Foglight Management Server is not running
A). Restart the Foglight application as described in Knowledgebase article 338992
B). If the Foglight application does not remain running after restarting, navigate into the logs folder (FMS_HOME\logs) and review the most recently created ManagementServer_YYYY-MM-DD_HHMMSS_XXX.log (.gz files are compressed with gzip and should first be uncompressed) for any relevant messages that might explain why the FMS is not starting up. Error messages can be researched in Supportlink or shared with Support to identify any issues.
RESOLUTION 2
Check the network connection from the monitored host through one of several methods. Some of these will rely on firewall port openings
RESOLUTION 3
Ensure that the correct URL or IP address has been entered in the web browser.
Foglight uses the following syntax: http://hostname:port/ or https://hostname:port/ where hostname and port represents the server when the Foglight Management Server application is running.
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