PROBLEM 1:
When trying to connect to an 11g database from the command line or within Toad, the following error, "ORA-01017: Invalid username/password; logon denied" is received. Connection to a 10g database through the command line works, but not to 11g. Connecting via SQL Plus also works fine.
PROBLEM 2:
After password expired and changing the password (and verifying change), receive ORA-01017: Invalid username/password; logon denied.
CAUSE 1:
Case sensitive passwords were introduced in Oracle 11g. When connecting to a database using Toad versions 9.1 and below the password is sent all UPPERCASE. Hence, the ORA-01017 error if the users password contains lowercase characters. Toad versions 9.1 and below do not support 11g Oracle Database.
CAUSE 2:
If connected to an 11g database using an Oracle 10g client then the password change fails. This also fails in SQL*PLUS. This is an Oracle issue.
RESOLUTION 1:
Upgrade to Toad for Oracle 9.5 or higher.
RESOLUTION 2:
Upgrade the Oracle Client to an 11g client.
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