Submitting forms on the support site are temporary unavailable for schedule maintenance. If you need immediate assistance please contact technical support. We apologize for the inconvenience.
SQL Server monitoring queries appear to cause excessive CXPACKET waits
Description
The top two SQL queries for a particular SQL Server are from Foglight, and are causing millions of CXPACKET waits. Average duration per wait is very low, but the amount of the waits seem excessive.
Cause
Foglight for SQL Server needs to query SQL Server System Tables. Once System Tables are queried, some of what is seen in various Database Dashboards and views are reflections of SQL Server background activity. This activity is not indicative of poor performance of the monitoring processes, but may indicate a need for tuning of the Instance(may include reviewing hardware requirements), database application logic and procedures. Foglight data collections can run at high frequencies, which may make them appear to impact system performance, when in fact they do not.
Resolution
Tune the MAXDOP on the instance to reduce the CXPACKET wait you are experiencing:
Foglight for Databases
6.1.0, 6.0.0, 5.9.7, 5.9.5, 5.9.4, 5.9.3, 5.9.2
Topic(s):
Troubleshooting
Article History:
Created on: 4/24/2015 Last Update on: 5/7/2023
Thank you for your feedback for Topic Request
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Welcome to Quest Support
You can find online support help for Quest *product* on an affiliate support site. Click continue to be directed to the correct support content and assistance for *product*.
Search All Articles
IE 8, 9, & 10 No longer supported
The Quest Software Portal no longer supports IE8, 9, & 10 and it is recommended to upgrade your browser to the latest version of Internet Explorer or Chrome.