During mail migration on some mailboxes the sync mail fail with the following COM exception :
2014-11-11 10:45:02.0614 Px970 Tx2D A7 C7 M775 Error System.Runtime.InteropServices.COMException (0x80004005): Error HRESULT E_FAIL has been returned from a call to a COM component.
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Cause 1
The MAgE agent is unable to process the OOF settings on affected mailboxes.
Cause 2
There are corrupt calendar entries that cannot be processed.
Cause 3
There are no OOF settings on the affected mailboxes whatsoever.
Resolution for Cause 2
Utilize the Microsoft Calendar Checking Tool with the -A switch and export to a .CSV. This will list any possible entries causing the HRESULT_E error.
http://blogs.technet.com/b/exchange/archive/2012/02/22/calcheck-the-outlook-calendar-checking-tool.aspx
Resolution for Cause 3
Set an internal and external OoO message via Powershell for the affected mailbox(es).