Submitting forms on the support site are temporary unavailable for schedule maintenance. If you need immediate assistance please contact technical support. We apologize for the inconvenience.
Core unable to communicate with license portal due to missing agent registry key
Description
When attempting to communicate with License portal the Core gives error message failed to connect and in the Rapid Recovery logs the error below is shown.
System.ArgumentNullException: String reference not set to an instance of a String. Parameter name: s Server stack trace: at ServiceHost.InMemoryHosting.InMemoryServiceHost.InvokeServiceMethod[T](String managementService, String method, IEnumerable`1 parameters) at ServiceHost.InMemoryHosting.CrossDomainCall.Call() at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs) at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
Cause
The agent ProtectionTimestamp is missing in the registry Computer\HKEY_LOCAL_MACHINE\SOFTWARE\AppRecovery\Core\Agents\AGENTID\ProtectionTimeStamp
Resolution
. In order to fix this follow these steps:
Shutdown Core
Open regedit
Remove agent that is missing "ProtectionTimestamp key
Start the core services
Add agent back into protection
If the affected agent is a replica on a target core do the following:
Remove the agent from replication keeping the recovery points on the target core
Remove the agent from replication in the source core
Stop the target core service
Remove agent that is missing "ProtectionTimestamp key
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Recommended Content
Product(s):
Rapid Recovery
6.6, 6.5, 6.4
Topic(s):
Troubleshooting
Article History:
Created on: 11/19/2014 Last Update on: 5/7/2023
Thank you for your feedback for Topic Request
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Welcome to Quest Support
You can find online support help for Quest *product* on an affiliate support site. Click continue to be directed to the correct support content and assistance for *product*.
The Quest Software Portal no longer supports IE8, 9, & 10 and it is recommended to upgrade your browser to the latest version of Internet Explorer or Chrome.