Chat now with support
サポートとのチャット

Enterprise Reporter 3.2.1 - Report Manager User Guide

Quest Enterprise Reporter Report Manager Introducing the Report Manager Running and Scheduling Reports Creating and Editing Reports Troubleshooting Issues with Enterprise Reporter Appendix: Log Viewer

Report Modification Example

The following example walks you through all of the steps necessary to modify a report.

Example: You want to modify the SQL Database report to only display databases from SQL Servers® running SQL Server® 2008. The report in the library does not include the version in it, so you will need to add that field to the report. You are going to change the title to reflect this, so you do not need to include the version for each database. This means you will use a hidden parameter for the version, and filter the data to show only the version you choose.

3
Click Edit Report.
4
Change the title of the report to SQL Server® 2008 Databases.
5
Click the Fields tab, and add the Version field to the report.
6
Click the Parameters tab and click Create.
10
Select the SQL Server® version you want (for example, SQL Server® 2008 is version 10.0).
11
12
Optionally, click Show preview to generate a sample of the report to review the edits.
13
Click OK in the Edit Report Definition dialog box.

Creating New Reports

If you are unable to get the information you want by modifying an existing report, you can create a new report from scratch. In cases when you cannot get the information you want by creating reports from existing fields and operators, or when you need to transform the data, you can use a custom query report.

For additional information, see Help Finding and Creating Custom Reports .

See also:

1
Select My Reports or a container within My Reports.
2
Click Create | Report.
4
Click the Fields tab.
5
Click the Report Type text box and navigate through the categories to select the Report Type that contains the fields you want in your new report.
8
Click the Parameters tab.
9
Click Add to create the required parameters. For more information, see Working with Report Parameters .
10
Click the Layout tab.
11
Optionally, click Auto-generate, Design new, or Import layout to create a report layout.
For more information, see Creating Report Layouts , Changing the Layout and Report Designer Tips and Tricks . For a full explanation of report layouts, see the Report Designer User Guide (Developer Express), located in the folder where you installed the Report Manager.
12
Optionally, click CSV Options tab and set the CSV export options for this report.
13
Click OK to close the Report Definition dialog box.
1
Select My Reports or a container within My Reports.
2
Click Create | Custom Query Report.
4
Click the Query tab.
6
Click Validate Query, then click OK.
For more information, see Creating Report Layouts and Changing the Layout and Report Designer Tips and Tricks . For a full explanation of report layouts, see the Report Designer User Guide (Developer Express), located in the folder where you installed the Report Manager.
10

Creating Report Layouts

The report layout determines the how information is grouped, sorted, and displayed in a report. Report layouts are optional; however, reports without a layout may only be exported in CSV format.

There are three ways to create a new layout for a report. 1) You can start from scratch, and manually place fields and text labels, set sorting and grouping and so on. 2) You can import a layout from an existing report. 3) Layouts can be auto-generated using the Report Wizard. By stepping through the six steps in the wizard, you can easily generate a layout that includes the relevant fields in a useful manner:

For a full explanation of the creating new layouts, refer to Report Designer Tips and Tricks and the Report Designer User Guide (Developer Express), located in the folder where you installed the Report Manager.

2
Click Auto-generate.
For more information, see Report Designer Tips and Tricks and the Report Designer User Guide (Developer Express), located in the folder where you installed the Report Manager.
4
Once you have completed the wizard, click OK to close the Report Definition dialog box.
2
Click Import layout.
For details on using the features of the Report designer, see Report Designer Tips and Tricks and the Report Designer User Guide (Developer Express), located in the folder where you installed the Report Manager.
Click OKTo create a new report layout from scratch
2
Click Design a new.
For details on using the features of the Report designer, see Report Designer Tips and Tricks and the Report Designer User Guide (Developer Express), located in the folder where you installed the Report Manager.
3

Setting CSV File Export Options

The definition for each report contains options that are applied when exporting the report to a CSV file. You may edit the following options to tailor the CSV file output to meet your needs:

For more information on how to export reports to raw, unformatted CSV files, see Running Reports or Exporting Reports to CSV and Other Formats from Different Containers .

1
Click My Reports.
Expand My Reports and select the category containing the report. In the treeview, select the report you want to edit.
3
Click the CSV Options tab.
5
Optionally click any Display Name to edit it.
7
Optionally, clear the Include column headers in exported file option to suppress column headers.
8
Click OK to close the Report Definition dialog box.
関連ドキュメント