When using the Windows Configuration Designer (WCD) to create a bulk provisioning package for Azure device migrations, an error may be displayed when attempting to “Get Bulk Token” if a default Microsoft Service Principal is missing from the tenant. This error occurs with the WCD from the Windows Store, the WCD from the Windows Assessment and Deployment Kit (ADK), and with PowerShell.
Bulk token retrieval failed. The operation returned an empty response. Please try again.
原因
Azure bulk token retrieval uses the following default Service Principal that is included with all Microsoft tenants: Microsoft.Azure.SyncFabric (AppID 00000014-0000-0000-c000-000000000000). If this Service Principal was not generated successfully during tenant provisioning, a bulk token cannot be retrieved.
対策
Use PowerShell to manually create the missing Service Principal with the default Microsoft settings and confirm it appears as an Azure Enterprise Application in the tenant. This will allow the Windows Configuration Designer to successfully retrieve the token to finish configuring the bulk provisioning package.