Device Cutover: Discovery Stuck in Queued status - "Root element is missing"
説明
Some devices are stuck in a Queued status for the Discovery, and we cannot get them restarted. The Application Event view log displays the following errors: Unable to poll for jobs Unable to read state file at C:\Program Files (x86)\Quest\On Demand Migration Active Directory Agent\Files\state.xml. Any interrupted jobs will not be recovered. There is an error in the XML document (0, 0).Root element is missing.
The state.xml file is empty(0 KB) size, located here: C:\Program Files (x86)\Quest\On Demand Migration Active Directory Agent\Files
原因
There is an issue with the state.xml file which is preventing the Discovery job from completing, even after Product Support has run a device status reset.
対策
From the device, go to C:\Program Files (x86)\Quest\On Demand Migration Active Directory Agent\Files
Delete the state.xml file
Open Services application and restart the On Demand agent service
The state.xml file should be created, and not be 0 KB in size
Open the Application Event viewer, there should not be any errors.
Submit a support request to have the Device job reset.
Provide support for the following:
ODM Region
Device sAMAccountName
Product Support will reset the device
This will allow the next device action to be performed (example: ReACL).