While trying to run a subscription you may receive an error in Event Viewer similar to:
Event Type: Error Event Source: QSchedExec Event Category: None Event ID: 1 Date: 6/6/2009 Time: 3:33:18 PM User: N/A Computer: COMPUTERNAME Description: No subscription delivered. The following errors occurred: Error 0x80004005. CreateFilterFile. Error=Cannot find report file. File: _Users/USERNAME%5Cauditadmin\First User - August 10th to August 16th.qrp" Error 0x80004005. CreateFilterFile. Error=Cannot find report file. File: _Users/USERNAME%5Cauditadmin\First User - August 17th to August 23rd.qrp" Error 0x80004005. CreateFilterFile. Error=Cannot find report file. File: _Users/USERNAME%5Cauditadmin\First User - August 1st to August 9th.qrp" Error 0x80004005. CreateFilterFile. Error=Cannot find report file. File: _Users/USERNAME%5Cauditadmin\First User - August 24th to August 31st.qrp"
原因
This error is because the account that is running the subscription is not the same user who created the report. And the report is saved in the My Reports section for the user who created it.
Because the account running the subscription does not have permissions to see the report in the other users My Reports, it gives this error.
対策
There are two methods to resolve this issue:
1. Run the subscription as the user who created the report (Go through the edit subscriptions wizard and it�??s the 2nd last thing asked for)
2. Move the reports out of my reports to anywhere else. e.g. right click on the report under my reports and click Move. Drop it under the corporate reports and configure the subscriptions to use this one.