Scheduled report and Service Desk Queue email fails to be sent when outbound relay SMTP configuration is set on port 25
説明
Under Settings > Network Settings > SMTP, using only Server name and port 25 (Anonymous, no authentication required), can cause issues with Kace SMA Scheduled Report and Service Desk Emails. This setting might generate error as the following in the logs: Report Fails to be sent R=smart_route defer (-32): lookup of host "port=25" failed in smart_route router 2022-07-27 14:31:31 1oGoct-0005Mo-PF <= reporter@ kacetest.com U=root P=local S=657 2022-07-27 14:31:31 1oGoct-0005Mo-PF no IP address found for host port=25 2022-07-27 14:31:31 1oGoct-0005Mo-PF == tester01@ kacetest.com R=smart_route defer (-32): lookup of host "port=25" failed in smart_route router 2022-07-27 14:31:31 1oGoct-0005Mo-PF Frozen
This error could be found in both Network setting SMTP and Service desk Queue SMTP “SMTP error from remote mail server after pipelined end of data: 530 5.7.57 Client not authenticated to send mail.” 2023-07-11 11:10:11 1qJGsN-0001me-De <= mainqueue@kacetest.com U=root P=local S=941 2023-07-11 11:10:21 1qJGsN-0001me-De ** tester@kacetest.com R=smart_route T=transport_587 H=office.com X=TLS1.3:TLS_AES_256_GCM_SHA384:256 CV=yes: SMTP error from remote mail server after pipelined end of data: 530 5.7.57Client not authenticated to send mail. [prod.outlook.com 2023-07-11T17:10:21.733Z 08DB812CCA57D05E] 2023-07-11 11:10:21 1qJGsX-0001or-On <= <> R=1qJGsN-0001me-De U=mailnull P=local S=2677 2023-07-11 11:10:21 1qJGsN-0001me-De Completed
原因
This issue is related to defect ID K1-32903 - Scheduled report email fails to be sent when outbound relay SMTP configuration is set on port 25 on Network Settings
対策
WORKAROUND: Adding authentication to Settings > Network Settings > SMTP, solves this situation. It is recommended to use an existing account, it will not have any impact on the Report and internal notifications of the SMA.
This is the recommended best practice, as mail servers tend to block emails coming from anonymous sources, such as the SMA, or when the mail server doesn't belong to one of the most common vendors, such as Google/GMail, Microsoft/Office 365/Azure, etc. Using anonymous also causes issues on the back-end of the SMA, such as internal mail loops, with the possibility of getting a partition full error and the SMA's services being affected.