The STANDBY Agent Managers in an HA configuration are in BROKEN state.
The following messages may appear in the Foglight Management Server logs:
com.quest.glue.adapter.service.ha.HAManager - No installer available for cartridge [Agent Type] [Agent Version Number]. Deployment to host [Agent Manager Name] in HA Partition ha has aborted.
CAUSE 1
Pending agent package upgrade in the PRIMARY Agent manager can prevent the STANDBY ones to complete package SYNC and appear as BROKEN.
CAUSE 2
Cartridge is disabled preventing the required agent packages to be deployed.
RESOLUTION 1
Complete pending agent upgrades in the Agent Managers dashboard. After completing the agent package upgrade the sync process should resume and the Agent Manager return to STANDBY status.
RESOLUTION 2
Re-enable required cartridges or if agent types are no longer in use then agent packages may need to be un-deployed.
The STANDBY Agent Managers can appear as BROKEN when the Foglight Management Server has failed to deploy one or more agent packages during synchronization and is not eligible for fail-over.
The list provided by the "Undeploy Packages" option on each of the agent managers, the HAManager service output from the JMX-Console / Diagnostic Snapshot or the 'HA Partition Summary' dialog available when clicking on the HA State from the Agent Managers dashboard can be used to confirm the packages currently deployed.
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