Symptoms:
During mail sync for a freshly provisioned mailbox with archive (using Power365), the following error is observed during migration of the archive mailbox:
Error,MigrationWorkerBase,None,"Mailbox copy exception",mail000002,"Microsoft.Exchange.WebServices.Data.ServiceResponseException: Access is denied. Check credentials and try again., Mailbox access denied. Owner: C29Lyu07Tk1ODB02; Accessing user: Archive mailbox:3229d224-5f8a-4114-b6e9-6169b189a811
Cause:
P365 mail migration may encounter access denied error when syncing archive mailbox if the mailbox and the archive were recently provisioned by P365 provisioning process. This is due to replication delay on the Microsoft O365 side and normally will be recovered when replication takes place.
Solution
User should resubmit the sync job after 2-3 hours which should allow the replication to take place and the sync should complete without error.
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