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Unable to recreate a database agent because agent or instance "is already monitored"
Description
A user cannot recreate an Azure SQL, Oracle, SQL Server, or DB2 database agent that was previously deleted and does not appear listed in the Agent Status panel. A popup appears that the agent or instance "is already monitored".
Cause
A topology may exist for the database agent that was deleted previously.
Resolution
This can indicates that either an agent has not yet appeared in the Global View dashboard or an agent was deleted in Agent Status but the configuration settings weren’t completely cleared out in “Clear Agent Data” and “Clear Agent Model Data”.
Delete the old agent topology and recreate the agent using the following steps.
Open Databases | Support Dashboard > Database technical Support
Switch between the DB types tabs (e.g. Oracle or SQL Server accordingly)
Click on Clear Agent data
Highlight the agent which is missing from Database Dashboard and has topology duplication
Click on the Delete button
Click on Clear Agent Model Data
Highlight the agent which is missing from Database Dashboard and has topology duplication
Click on the Delete button
Rerun the Database Wizard and add the instance
If your system has a lot of database agents seeing the agent in the Global view is not immediate and it can take up to a couple of minutes to appear. Deactivating and reactivating the agent in Agent Status can sometime expedite the agent reappearing.
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
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