Issue
Users were not able to logon or access their mailboxes after DirSync profile was run as these objects were updated by DirSync.
Cause
Typically DirSync does not update any mailbox enabled objects in the target; however, if the profile is configured with Update Mailbox Enabled Object setting set to True, DirSync will bring source objects Exchange Attributes to the target. Hence it may corrupted the target AD objects.
Solution
Make sure the profile is configured with all MSExchange related attributes removed in the mapping field. In addition, the following attributes should be removed as well:
LegacyExchangeDN
MailNickName
TextEncodedOrAddress
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