Issue
Migrations are running smoothly with version 19.03, but I ran into the following autodiscover issue for a few users and mailboxes. Outlook is patched to the current level. What is causing this error?
End of AutoDiscover and Profile Creation Log
Error: AutoDiscover Response Parse Error: No document element found.
Entering BTExchangeMapi::UnInitialize
Exiting BTExchangeMapi::UnInitialize
Deleting AutoDiscover Response file :
Deleting AutoDiscover Response file
Exiting BTNotesMigrateUsersMailFile()
Exiting NotesUserMigrate()
Done migrating <User Name>
<User Name> Migration Failed
Solution
Resolved with version 19.09 and newer
There is an issue if the Target mailbox has a delegate associated with the mailbox.
Is this user (mailbox) being migrated a delegate of this other user in the target?
If yes, remove the member names from being the delegate till after migration is complete.
Do not migrate this mailbox right away. This change takes time to sync on the target servers
Root Cause
There is a problem with Outlook trying to do auto mapping for the delegate mailbox during the migration. The migration worker creates an Outlook profile with a connection to its mailbox then adds the target user account mailbox to that profile (essentially as a delegate) in order to migrate the data.
In this case Outlook was trying to add the delegate account as well for the user mailbox which it is not meant to do. Basically it was attempting to add a delegate mailbox to an already delegated mailbox as far as the Notes Migrator Outlook account is concerned.
We just started to see this issue come up recently, if you do have a migration issue on initialization like that again then check if the target user mailbox does have delegate access to another account.
We would also recommend an upgrade to the current Notes Migrator GA version (19.09 or newer) if this does occur again it would be good to have the newer migration engine in place for validation.
That is not immediately necessary but it is a simple enough upgrade process. If you have an active maintenance plan, please contact support@binarytree.com for download details. Contact your Sales Account Manager if your maintenance has expired.