All InTrust Agents no longer appear in InTrust Manager and "ADC Error: User not found " is recorded in the InTrust log
説明
All InTrust Agents no longer appear in InTrust Manager | Configuration | InTrust Servers | Agents
In addition, there are continual errors in the Windows Event Viewer InTrust Log similar to the following:
Event ID: 13650
Type: Warning
Source: InTrust Agent Manager
Operation: Security
Computer: 10.10.10.10:50007
Description: Incoming connection attempt has been failed. Source address: 10.10.10.10:50007. Error text: ADC Error: User not found (0x8adc3207).
原因
Cause #1: Agents are not communicating with the InTrust server(s) after it was recently upgraded due to incompatible FIPS encryption.
Cause #2: The users_data_base.1 file contains unexpected data and cannot be read by the InTrust Server. This can be verified by viewing the users_data_base.1 file which is typically located in the following location:
If the users_data_base.1 is 1KB or less, then the file contains unexpected data and cannot be read by the InTrust Server.
対策
If it is Cause #1, make sure the "FIPSmigrator tool" was run a second time against the InTrust Cfg database after the upgrade is finished. If unsure, rerun it (default path: \Program Files(x86)\Quest\InTrust\Server\ADC\SupportTools), then restart InTrust services.
If it is Cause #2, you will need to rebuild the users_data_base.1 file using the following process on each InTrust Server in the organization:
Open a command prompt and browse to the following directory:
Type the following where PASSWORD is the password that you want to use for initial communication with agents (InTrust organization password is fine but this can be anything you specify) and press Enter:
adcsecadm.exe -cu newcomer srpserver PASSWORD
Type the following and press Enter (Any possible warnings can safely be ignored, for example, 'group already exists', as long as the commands execute.):
adcsecadm.exe -ag Agents
Restart the Quest InTrust Server service and all dependent services.