Launching Toad via Performance Analysis either by killing a session or through Advisories, throw the following error:
"Unable to open Toad, please verify that it is correctly installed"
If the client machine has multiple copies of Toad (e.g. 9.7.2, 10.1, 10.5.1), it does however launches version 10.1 but not 10.5.1.
Old Quest branded Toad versions:
CAUSE 1
PAO GUI is looking for the Toad installation path in this registry key - HKEY_LOCAL_MACHINE\SOFTWARE\Quest Software\TOAD. Version 10.5.x does not use this registry anymore.
CAUSE 2
PASS GUI is looking from HKEY_CURRENT_USER\Software\Quest Software\Toad for SQL Server. This normally happens if the user launching Toad from PA GUI was not the one who installed the Toad software.
For Dell branded Toad Versions:
The PA client is under limited support and this broken feature will not be fixed.
WORKAROUND
Please use the "Copy to Clipboard" button the pop up window which appears when you click on "Kill Session". Now open Toad to run the copied statement.
Old Quest branded Toad versions:
WORKAROUND 1
If only Toad for Oracle version 10.5.1 is installed, create a registry key as follows:
[HKEY_LOCAL_MACHINE\SOFTWARE\Quest Software\TOAD]
Create the following String values:
CLIENT = C:\Program Files\Quest Software\Toad for Oracle 10.5
SERVER = C:\Program Files\Quest Software\Toad for Oracle 10.5
WORKAROUND 2
If multiple Toad installations are installed and you want to launch version 10.5.1 then modify the CLIENT and SERVER string values under HKEY_LOCAL_MACHINE\SOFTWARE\Quest Software\TOAD to reflect the installation folder of 10.5.1
WORKAROUND 3
For Performance Analysis for SQL Server launching Toad for SQL Server:
© 2024 Quest Software Inc. ALL RIGHTS RESERVED. Conditions d’utilisation Confidentialité Cookie Preference Center