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The following messages are seen in the Sybase agent log
JZ0TO: Read operation timed out
JZ0T3: Read operation timed out
JZ0TO: Login timed out Check that database server is running on the host and the port number specified, also the check the database server for other conditions (such as a full tempdb) that might be causing it to hang.
Cause
Issue is with the connection to Sybase or the overall load on the host.
Not a Foglight issue
Résolution
Users can try to increase the timeout to a higher number (e.g. 300000 or 900000) by following the steps below:
Go to Administration | Agents | Agent Status
Select the problematic agent and click on Edit Properties
Now click on the link Modify the properties for this agent only
Update the two parameters
DB Connection Timeout (milliseconds)
On-Demand DB Query Connection Timeout (milliseconds)
Click on Save
In Collection Details, click the Edit button and increase the value in the Query Timeout column for any specific collections that are timing out, click the Enter button, and then Save.
Finally deactivate and active the agent to force the change pushed out to the agent.
For troubleshooting:
confirm the database server is running
reduce the number of maxRows for the collection back to the default values (e.g. 400 rows for Top SQL)
check the port is correct
check that the server has sufficient processing capability
review the network connection to the server from the FglAM
try an external java based application to connect to the Replication server
However this is just the initial connection to the host, unless the performance on the server is reviewed other collections will likely also timeout during monitoring.
Créé le : 4/21/2022 Dernière mise à jour le : 5/23/2024
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