vRanger VA replication fails with error message:
An internal error occurred during execution, please contact Quest support if the error persists. Error Message: Trying to map Vizioncore.vRanger.Domain.Jobs.ReplicationJobTaskBE to Vizioncore.vRanger.Domain.Replication.ReplicationConfiguration. Using mapping configuration for Vizioncore.vRanger.Domain.Jobs.ReplicationJobTaskBE to Vizioncore.vRanger.Domain.Replication.ReplicationConfiguration Exception of type 'AutoMapper.AutoMapperMappingException' was thrown
This generally happens after editing a job for a VM on a host/cluster when the vRanger virtual appliance (VA), for the host/cluster that the failing VM is on has either been removed, deleted, or powered off. And is still showing in the vRanger VA inventory screen.
If this is the case when you verify the VA for affected host/VM it will show up with IP address "unknown."
ie. Screen shot below in additional information section.
If the VA is powered off you will just need to power back on.
If it has been removed from inventory re-add to inventory from vSphere client data store browser and power on.
If the VA has been deleted you will need to remove from vRanger and re-deploy.
