Unable to add Virtual Center to vRanger inventory after upgrading Virtual Center. Get a connection error.
Also, attempts to log in to vCenter Server by using a vSphere Client instance installed on a Windows Server 2003 machine fails with the following error message:
An unknown connection error occurred. (The Client could not send a complete request to the server. (The underlying connection was closed: An unexpected error occurred on a send.))
The issue is caused by the lack of support for some SSL ciphers on Windows Server 2003.
The following workaround found in the vCenter Server 5.1 Update 2 Release Notes, resolved the issue for the end user.
Add the following lines to the vCenter Server configuration file at C:\Documents and Settings\All Users\Application Data\VMware\VMware VirtualCenter\vpxd.cfg:
<config>
<vmacore>
<ssl>
<cipherList>"HIGH:RC4-SHA:RC4-MD5"</cipherList>
</ssl>
</vmacore>
</config>
Restart the VMware VirtualCenter Server service.
NOTE: The login attempt might still fail if you use the vSphere Client to connect directly to an ESXi host.