Chat now with support
Chat with Support

Toad for Oracle 12.12 - Toad 使用指南

目录 欢迎来到 Toad Toad 资源 所需特权 创建和管理数据库连接 编辑器基本信息 模式浏览器基本信息 数据网格基本信息 使用数据 使用数据库对象 使用代码
编写语句和脚本 使用查询生成器 执行语句和脚本 保存语句(SQL 重新调用) 使用 PL/SQL 对象 调试 分析代码 优化 SQL
自定义 Toad 环境 将其他 Quest Software 产品与 Toad 搭配使用

比较数据库

使用数据库对象 > 比较对象 > 比较数据库

您可以在数据库或数据库快照文件之间比较数据库级对象,例如表空间、角色、用户等等。

此功能仅限 DB Admin 模块可用,此模块包括在多个 Toad 版本中或者可以单独购买。

如要比较数据库

  1. 选择数据库 (Database) | 比较 (Compare) | 数据库 (Databases)。
  2. 按需要填写字段。 
    选项卡 字段 描述
    数据库    
     

    参考源

    选择一个实时数据库或数据库定义文件用作比较的基础。如果您执行同步脚本,则更新目标数据库以匹配参考源。

    提示:如果您选择创建数据库快照文件 (Create Database Snapshot File),您可以在文件名中使用变量。默认情况下,Toad 包括 %DATEFILE% 和 %TIMEFILE% 变量,在创建定义文件时便将当前日期和时间插入文件名。

     

    目标和输出

    单击实时数据库 (Live Databases)快照文件 (Snapshot Files) 字段中的 ,以添加目标数据库进行比较。您可以重复此步骤将多个目标数据库与来源进行比较。

    提示:右键单击目标,可进行编辑,删除或用参考源切换。

    选项

     
     

    数据库对象类型

    选择您想要比较的对象类型。减少对象类型可以减少完成比较所耗费的时间。

    提示:右键单击以选中或取消选中所有字段,以及保存或重新调用您的设置。

     

    “安全删除”用户、表空间及配置文件

    如果没有任何对象,则仅删除用户或表空间,如果没有指派任何用户,则删除配置文件。

    对象集

     

     
     

    指定对象集

    选中以确定要比较的具体对象集。与选项选项卡相比,这可以让您更多地限制比较。注:如果比较数据库因与其他对象比较命令(针对用户选择)结果打开,则选定用户会显示在此处。

    单击 以添加一个对象集。如果您已经加载了对象,会出现一个确认对话框,询问您是否想要在加载新对象之前清除网格。单击是 (Yes) 以重新开始,或单击否 (No) 将新对象追加到网格中。

  3. 单击 以执行,或将选择保存或计划为 Toad 操作。请看联机帮助中的自动化设计器概述了解详情。

    提示:如要从命令行执行操作。请看联机帮助中的通过命令行执行操作了解详情。

  4. 复查结果选项卡中的差异。复查以下内容以获得附加信息:

    任务

    采取的操作

    显示选定对象的同步脚本。

    选择对象,然后单击

    查看一个对象的差异

    选择对象,然后单击

    查看其他目标的差异 目标数据库字段中选择目标(仅适用于您选择了多个目标进行比较的情况)。
  5. 如要同步数据库,选择同步脚本 (Sync Script) 选项卡,然后单击 立即从编辑器执行,或单击 计划其执行时间。

    注意:执行前彻底复查此脚本,以防发生意外数据损失。

 

重建对象

使用数据库对象

Toad 可让您查看、添加、修改和获取有关数据库对象的信息。您可以快速使用这些对象,而无需使用 SQL 命令。

 

关于重建对象

使用数据库对象 > 重建对象 > 关于重建对象

使用重建多个对象 (Rebuild Multiple Objects) 窗口识别需要重建的对象,然后设置条件以同时重建这些对象。

重建多个对象

您也可以从模式浏览器的更简单界面中,一次重建一个索引或表。

 

重建表

使用数据库对象 > 重建对象 > 重建表

使用此函数重建一个表,包括删除和重命名列。

注:

  • 您可以使用重建多个对象功能,同时重建多个表。
  • 您必须拥有模式才能从中重建表。

如要重建一个表

  1. 单击标准工具栏上的 image\Toad0015.gif,打开模式浏览器。
  2. 在左侧右键单击表,并选择重建表 (Rebuild Table)。

    提示:您也可以选择数据库 (Database) | 优化 (Optimize) | 重建表 (Rebuild Table)。

  3. 在选项 (Options) 选项卡中,按需要选择设置。
  4. 在表存储 (Table Storage) 选项卡和索引选项 (Index Options) 选项卡中,按需要选择参数。

    注:此窗口中的参数由 Oracle 定义。请参阅Oracle 文档了解详情。 您可以在 Knowledge Xpert 中找到关于参数的详细信息。Knowledge Xpert 是一个丰富的 Oracle 技术资源,您可以在“跳转搜索”中搜索资源。跳转搜索

  5. 要添加、编辑或拖放列,使用“列”选项卡上的工具栏按钮。
  6. 如要查看 ALTER 语句,选择脚本选项卡。
  7. 要执行重建,单击“重建表”工具栏上的 。注:您也可以使用工具栏按钮,以计划、复制、重新生成并保存脚本。

 

Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating