Chat now with support
Chat with Support

Toad Data Point 4.2 - Installation Guide

Configure Toad Layouts

Toad can emulate the layout and settings of other products. Use the Configuration Wizard to select a pre-defined layout that matches Toad® for Oracle®, SQL Navigator, or your native database tool. The Configuration Wizard also allows you to specify a skin and grid color.

If you want to group documents using Toad's built-in workflow: Understand, Query, Report, and Automate, select the Toad for Data Analysts (Original) option. Then open the Configuration Wizard again and select Custom to configure Toad behavior, such as showing/hiding windows, or opening and grouping documents according to the selected workflow group.

You can also manually rearrange windows and panes to customize the Toad workspace. See Customize Your Toad Workspace for more information.

To configure Toad layout using the Configuration Wizard

  1. Select Tools | Configuration Wizard (ALT+T+F).

  2. To match the look of another product, select a layout option and click Finish.

    Review the following layout options before selecting:

    Layout and Settings Page

    Layout options:

    • Toad Data Point 3.0—Applies shortcut keys used by Toad Data Point, opens default windows, and adds the Wizard toolbar.

    • Toad for Oracle—Applies shortcut keys used by Toad® for Oracle® and automatically opens the Project Manager, Editor, SQL Recall, and Output windows.

    • MS Query Analyzer—Applies shortcut keys used by Query Analyzer and automatically opens the Object Explorer, Code Snippets, and Editor windows.

    • MS Management Studio—Applies shortcut keys used by Management Studio and automatically opens the Connection Manager and Editor windows.

    • SQL Navigator—Applies shortcut keys used by SQL Navigator and automatically opens the Navigation Manager, Object Explorer, Editor, and Code Snippets windows.

    • Toad for Data Analysts (Original)—Applies shortcut keys used by Toad for Data Analysts. This option also displays the Grouping (Toad workflow) toolbar and Wizard toolbar.

    • Custom—Applies shortcut keys used by Toad Data Point. This option allows you to select skin and grid styles, as well as Database Explorer display options.

      Use this option to customize the Toad for Data Analysts layout if you have previously selected it.

    Tip: You can set or modify individual keyboard shortcuts in Keyboard Options in Tools | Options | Environment | Keyboard.

    Note: If you select a new layout, you may need to restart Toad to see the changes to the Grouping and Wizard toolbars.

  3. To customize your layout, select Custom and click Next. Then specify options on each page of the wizard. Review the following for additional information:

    Page

    Options

    Look and Feel

    Select a skin and grid style.

    • Skin—Applies the skin style you select to document windows, tool windows, and modal dialogs.

    • Grid style—Applies the grid style you select to the data grid only.

    A preview of the selected style is automatically displayed in the wizard and in the grid.

    Tip: You can change the skin and grid style later in Tools | Options | Environment | Interface.

    Database Explorer Style

    Specify how objects display in the Object Explorer window.

    Tip: Click in the Object Explorer at any time to switch to a different view style.

    Quick Guide

    Displays a Quick Start Guide that lets you quickly launch frequently used features and tutorials until you are more familiar with the application.

    Tips:

    • To view this window at anytime, select View | Quick Guide from the menu.

    • To hide this window when starting Toad, select the Do not show on start up checkbox at the bottom of the Quick Guide window.

    Group Documents

    Applies to the Toad for Data Analysts (Original) layout. Select this layout option prior to customizing.

    Specify one or more of the following options:

    • Use document groups—Associates each open document with its respective group in the Groupings (Toad workflow) toolbar.

    • Hide windows per group—Displays only those windows that are associated with the selected group in the Groupings toolbar. For example, if the Query group is selected and a Query Builder window is open, it will be hidden when you select the Report group.

      Note: Unless the Hide windows per connection checkbox is selected, any connections that have a window open for this group display.

    • Hide windows per connection—Displays only those windows for the current connection that are associated with the selected group.

    Tip: To hide the Grouping toolbar, select Tools | Customize, and then deselect the Grouping toolbar in the Toolbar tab.

    Group Document Defaults

    Applies to the Toad for Data Analysts (Original) layout. Select this layout option prior to customizing.

    Select the default window to open when selecting a group from the Grouping toolbar.

    Understand

    • Database Diagram—Easily identify relationships between tables via foreign keys.

    • Database Explorer—Drill-down to details for each object.

    Query

    • Query Builder—Quickly create complex queries and subqueries using a graphical interface.

    • SQL Editor—Powerful editor for writing SQL queries and scripts.

    Report

    • Excel—Automatically export query results and open them in Excel.

    • Toad Report—Send query results to the Toad Data Report wizard.

    Wizard Bar

    Select to display the Wizard bar, a toolbar containing frequently-used actions for the currently open window. It displays along the bottom of the Toad window.

    Tip: To modify this option later, use the Configuration Wizard.

    Connection Documents

    Specify which type of new document to automatically open when a new database connection is created.

    Tip: You can modify this option later in Tools | Options | Database | General.

    Additional Settings

    Specify whether to automatically add files to the Project Manager when saving, executing, or sending the files to a report. This option can help you locate and manage your work.

  4. Click Finish when you are done customizing.

Customize Your Toad Workspace

You can customize your Toad workspace by re-arranging windows and panes. For docked panes selected from the View menu, Toad remembers the configuration of your last open session and displays it when you re-launch the application.

To rearrange windows and panes

  1. Open a Toad pane by selecting it from the View menu.
  2. Drag the pane to a new location in the Toad workspace.
  3. Drop the pane into the desired section of the workspace when it becomes highlighted.
  4. To move an open window, drag it to the desired area of the workspace and drop it into a highlighted section.

Create Connections

Understand Toad Connections

Review this topic to learn about open database connections in Toad.

Toad Open Connections

In Toad, an open connection in the Connection/Navigation Manager represents one or more actual connections to the database or data source. When you open a database connection in Toad:

  • Toad creates an initial database connection for general use.
  • Toad also creates a separate database connection for each Editor (the first time you execute a statement) and for each Data tab in the Database Explorer (the first time you select the tab and query data).

    The connection associated with the window (or tab) remains open until you close the window. If a window has an associated connection, but a statement is not currently executing, the connection is in an inactive state.

To view information for an open connection

  • To view the number of actual database connections that exist for a Toad connection, including the number of active connections, place the cursor over the connection in the Connection/Navigation Manager pane or in the connection drop-down list.

To use the Background Processes pane

  • When a statement is executing, a progress bar displays in the Status bar located at the bottom of the Toad application window. Click the executing progress bar to open the Background Processes pane.
  • To cancel statement execution, use the Background Processes pane.

    Note: It is recommended that you cancel only your own processes, because terminating Toad activities could cause unexpected behavior.

Sharing a Connection Among Windows

You can instruct Toad to share an open connection among windows. In this way, the Editor windows and Data tabs can share the same connection when the connection is inactive.

To share a database connection among windows in Toad

  1. Select Tools | Options | Editor | General.
  2. Clear the checkbox for the Use individual connection for each open editor option.

  3. When this option is not selected, Toad attempts to use a single connection for any new windows or query execution. For example, if you share a database connection, you can execute a query in the Editor, execute another query in a new Editor, and then select the Data tab from the same connection.

    If the single connection is in use when Toad attempts to execute it, the following occurs:

    • (DB2 and Oracle only) If your database supports executing multiple queries simultaneously on a shared connection, the query is placed in a queue and executes as soon as the current operation completes.
    • If your database does not support executing multiple queries on a shared connection, a dialog prompts you to either permanently associate the window with a new database connection, cancel the previous operation, or add the query to a queue until the current operation completes, and the execute it. If you place multiple queries in the queue, each one executes in the order that it was added to the queue.

Note: Although you can share a database connection, any commits apply to the selected window only.

Create Access Connections

Although this connection uses the ODBC driver, it is easier and faster to connect using this method. See Troubleshoot Access Issues for more information about troubleshooting connection issues.

Notes:

  • The Toad Sample Database and established connection that comes pre-loaded in Toad Data Point is an Access database. The connection information for this database is: 

    Database file = C:\Program Files\Quest Software\ToadInstallDirectory\Plugins\Odbc\Sample Database\Quest_Stage.mdb

    Additional sample files for this database are available in the Project Manager.

To create an Access connection

  1. Click on the toolbar (ALT+F+N).

  2. Select Access from the Group list box.

  3. Review the following for additional information:

    Database file

    Select the database to use when connecting.

    MDW file

    Select the MDW file that is linked to the database.

    Password

    Enter the password to use when connecting.

    Tip: After connecting, you can set a master password to further secure your connection in Tools | Options| Environment | Security.

    Category

    Select or create a category if you want to color code Editor tabs for a specific connection. This can help differentiate between development and production databases. You can also set an option to color code the Object Explorer pane and object editor windows (Create, Alter, Drop, etc.).

      Click here to view a video of this feature.

  1. Click Connect to connect immediately while saving the connection information. Optionally, click Save to save the connection without connecting.

Considerations and Limitations

Consideration/Limitation Description

Microsoft Access 2016 64-bit

Office 365 64-bit

To successfully create a connection to an Access database using Microsoft Access 2016 64-bit, the Microsoft Access Database Engine is required and might not have been included in the Access installation. In addition, the architecture (bitness) of the engine must match the bitness of Toad.

If using 64-bit Toad, the 64-bit version of Microsoft Access Database Engine is required.

If using 32-bit Toad, the 32-bit version of Microsoft Access Database Engine is required.

  1. You can download the 64-bit or 32-bit Microsoft Access Database Engine components at: https://www.microsoft.com/en-us/download/details.aspx?id=13255.
  2. Be sure to select the appropriate version (64-bit or 32-bit) of the AccessDatabaseEngine.exe installer to match the bitness of Toad.

Tip: Connections are stored in the connections.xml file and can be found by clicking the Application Data Directory link in Help | About.

Click here to view a video about creating connections in Toad Data Point

Related Documents