Chat now with support
Chat with Support

Welcome, erwin customers to Quest Support Portal click here for for frequently asked questions regarding servicing your supported assets.

Toad Data Modeler 7.1 - Release Notes

System Requirements

Before installing Toad Data Modeler 7.1, ensure that your system meets the following minimum hardware and software requirements.

  Minimal Requirements Optimal
Memory 1 GB 4 GB
Hard Disk Space 400 MB 1 GB
Operating System

Microsoft Windows 10 (64-bit)
Microsoft Windows 8.1 PRO (64-bit)
Microsoft Windows Server 2016 (64-bit)
Microsoft Windows Server 2012 (64-bit)
Microsoft Windows Server 2008 R2 (64-bit)
Microsoft Windows 7 (32-bit or 64-bit) *

*For Toad Data Modeler 64-bit version, only 64-bit version of the operating system can be used.

Other Requirements .NET 4.0 or later  

Virtual appliances

Review the following information about using Toad Data Modeler in virtual environments:

Requirement Details
Application Toad Data Modeler has been tested for Citrix support on the Citrix XenApp 6.5.
Desktop (VDI) Issues during printing using virtual printers - The problem occurs only in case of print from a local machine (all printers from local machine are visible on vWorkspace). If the virtual printer is installed on vWorkspace directly, the issue will not occur.
Server Oracle VM 3.0
Toad Data Modeler has been tested with ESXi VMware 5.5.

Toad Data Modeler may work correctly in virtual environments other than the tested ones. In case of virtual servers, support for Toad Data Modeler is provided on the basis of supported operating systems.

Cloud database services

Toad Data Modeler supports the following cloud-based database services:

  • Oracle Database as a Service

Upgrade and compatibility

It is not possible to open models created in Toad Data Modeler 7.1 in versions earlier than 6.0.

Version 5.2 introduced new system of relationship lines. Models created in version 5.1 and lower are automatically converted to the newer format. Backup your models prior to opening them in version 5.2 or higher.

Do not open and re-save models originally created in a higher version of Toad Data Modeler in a lower version of Toad Data Modeler.

Supported Database Platforms

Supported model types

  • Logical
  • Universal
  • Physical

Supported databases

  • Amazon® Aurora MySQL 5.6
  • Amazon® Aurora PostgreSQL 9.5
  • Amazon® Redshift 1.0
  • IBM® DB2® z/OS® 10, 11
  • IBM® DB2® LUW 9.5, 9.7, 10.1, 10.5, 11.1
  • Greenplum Database® 4.1, 4.2
  • Ingres 9.3, 10.0
  • EDB Postgres Advanced Server 10
  • Microsoft® Access® 2007-2010
  • Microsoft® Azure® SQL Database V12
  • Microsoft® SQL Server® 2005, 2008, 2012, 2014, 2016, 2017
  • MySQL 5.0, 5.1. 5.5, 5.6, 5.7
  • Oracle® 10g, 11g R1, 11g R2, 12c R1, 12c R2, 18c, 19c
  • PostgreSQL 9.0, 9.1, 9.2, 9.3, 9.4, 9.5, 10, 11
  • SQLite 3.7
  • SAP® SQL Anywhere 17
  • SAP® ASE 16.0
  • Sybase® ASE 15.5, 15.7
  • Sybase® IQ 15.2
  • Sybase® SQL Anywhere 11
  • Teradata 13
  • Vertica Database 8.0
  • Other (Universal Model)

Note: For more information about the level of support please see Help, section Introduction | Supported Databases.

Product Licensing

To activate a purchased commercial license

  1. Open Toad Data Modeler.
  2. Select Help | Licensing.

Getting Started with Toad® Data Modeler

Getting started with Toad Data Modeler 7.1

Upgrade and installation instructions

The Toad Data Modeler release package contains the following products:

  • Installation file of Toad Data Modeler (MSI)
  • Product Documentation, including:
    • Release Notes (PDF)
    • Installation Guide (PDF)

Installation Instructions

Refer to Toad Data Modeler Installation Guide for installation instructions.

Additional resources

If applicable, point to related references, provide a list of corresponding documents, videos, or identify the community where additional information can be obtained. Otherwise, delete this section.

Additional information is available from the following:

Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating