Chat now with support
Chat with Support

Toad Data Modeler 7.0 - User Guide

Introduction User Interface Models and Model Objects
Physical Data Model
Entity Relationship Diagram Objects Basic Database Design Advanced Database Design
Universal Data Model Logical Data Model Working with Model Objects
Features and Tools
Application Variables Export/Import DDL Script Generation Graphics Model Actions Print Create New Project Reports Reverse Engineering Scripting and Customization About Templates Tips and Tricks Toad for Oracle Integration Toad Intelligence Central (TIC) Integration Tools Version Control
Options and Configuration Databases
Amazon Redshift 1.0 IBM DB2 LUW 9.5 IBM DB2 LUW 9.7 IBM DB2 LUW 10.1 IBM DB2 LUW 10.5 IBM DB2 LUW 11.1 IBM DB2 z/OS 10 IBM DB2 z/OS 11 Greenplum 4.1 Greenplum 4.2 Ingres 9.3 Ingres 10.0 EDB Postgres Advanced Server 10 Microsoft Access 2007/2010 Microsoft Azure SQL Database V12 Microsoft SQL Server 2005 Microsoft SQL Server 2008 Microsoft SQL Server 2012 Microsoft SQL Server 2014 Microsoft SQL Server 2016 Microsoft SQL Server 2017 MySQL 5.0 MySQL 5.1 MySQL 5.5 MySQL 5.6 MySQL 5.7 MySQL 8.0 Oracle 10g Oracle 11g Release 1 Oracle 11g Release 2 Oracle 12c Release 1 Oracle 12c Release 2 Oracle 18c Specifics - Oracle 12c Release 2 PostgreSQL 9.0 PostgreSQL 9.1 PostgreSQL 9.2 PostgreSQL 9.3 PostgreSQL 9.4 PostgreSQL 9.5 PostgreSQL 10 SQLite 3.7 Sybase ASE 15.5 Sybase ASE 15.7 SAP ASE 16.0 Sybase IQ 15.2 Sybase SQL Anywhere 11 SAP SQL Anywhere 17 Teradata 13 Vertica Database 8.0
Copyright Legal Notices

Status of Items in Grids

Various types of status are shown in the following examples of attributes and entities.

  1. Normal state
  2. Attribute Customer ID is being edited. - The item is in grey.
  3. A new attribute has just been added, the change has not been confirmed yet. (After the change is confirmed, the status will change and set to Normal. Until creation of the new item is confirmed, it's not possible to edit it.)
  4. The attribute has been modified in the grid directly (see the changed name). The change has not been confirmed yet.
  5. Item NewAttribute has just been deleted, the change has not been confirmed yet.
  6. Deletion of item NewAttribute has been confirmed by clicking the Apply button. The item is marked as deleted and will not be displayed when you open the Entity Properties form/Attributes tab next time.
  1. You've opened two instances of the same Entity Properties form and started editing properties in one of them. That one will be marked by E and will be editable, while the other form will be marked by n/a and won't be editable.

Note: By default, you can open only one instance of a form. To open more instances at the same time, go to Settings | Options | General | and uncheck the Allow One Instance of Form checkbox.

Menus

The following menus are available in Toad Data Modeler:

TIP: Find any menu option easily by typing its first letters into Jump To...

File Menu

The following options are displayed when there is at least one Designer opened inside the Application Window.

Option Description
New | Project

Creates a new project, displays the New Project settings dialog.

New | Model

Opens the New Model dialog.

Supported models:

  • Physical Data Model
  • Universal Data Model
  • Logical Data Model

TIP: Right-click the dialog to select the display of the options (Large Icons, Small Icons, List).

 

Model Name -  Define a name of your model. (Also, you can change the name later in the Application View or Model Explorer (press F2).)

 

Notes:

Note:

  • Database Name - A database for which the model has been created  (e.g. Oracle 10g). The database name information can be found at the bottom of the Application Window, or it is displayed in the pop-up hint when you point your mouse cursor at the Model Name in the Application View or Model Explorer.
  • Model Name - In Toad Data Modeler, Model Name should be understood as a title of a document that is saved.
  • File Name - A name of file under which the model is saved. File Name is defined after you select Save Model or Save Model as.

New | Gallery

Opens the Gallery Edit dialog.

You can create Gallery to store frequently used parts of your models such as entities, attributes, stored procedures and other objects. You can then access these parts from any project.

Open | Project

Displays the Open dialog in your default Projects folder.

Open | Model Displays the Open dialog in your default Models folder.

Open | Samples

Displays the Open dialog in your default Samples folder.
Open | Gallery Displays the Open dialog in your default Gallery folder.
Open | Sample Gallery Displays the Open dialog in your default Sample Gallery folder.

Recent Files

Contains a list of recently opened files.

Save Model

Saves opened model or opens the Save file dialog.

Save Model as

Opens the Save file dialog and allows you to save your model to another folder or in another file format.

Reverse Engineering | Connections

Opens the Connections dialog.

Reverse Engineering |
Reverse Engineering Wizard

Opens the Reverse EngineeringWizard.

Import | Toad for Oracle Project

Displays the Open dialog in you default Toad Data Modeler folder.

Import | Toad for Oracle ERD Displays the Open dialog in your default Toad Data Modeler folder and also opens Connections dialog.
Import | Case Studio 2 Model Displays the Open dialog in your default Models folder. This option is used for importing model files from Case Studio 2.
Import | Import from Excel Opens the Import from Excel dialog.
Import | Import from CSV Opens the Import from CSV dialog.
Export | Export to Excel Opens the Export to Excel dialog.

Export | Export to CSV

Opens the Export to CSV dialog.

Export | Export to Image

Opens the Export to Image dialog.

Close | Model

Closes currently selected model.

Close | All Models Closes all opened models.

Page Setup

Opens the Page Setup dialog.

Print Preview

Displays a preview of your ER diagram as it will look when printed.

Print

Opens the Print dialog to configure printer settings.

Exit

Finishes your work in Toad Data Modeler. Before closing the application your are asked to save changes you made in your models.

This is done in the Application Close dialog (shown on the screenshot below), where all of your opened models and projects are listed. Select all the items that you want to save, all items that have been modified are selected to be saved by default.

Edit Menu

 

 

The Edit menu mostly contains basic actions such as Copy, Cut, Paste, Undo and Redo and also several options to select objects on Workspace.

Option Description

Undo

Undoes the last action.

Redo

Redoes the last undid action.

Cut

Cuts selected object to clipboard.

Copy

Copes selected object to clipboard.

Paste

Pastes the copied/cut object from clipboard.
Capture Image into Clipboard Choosing this option allows you to select an area on your Workspace. This area will be captured as an image and stored in your clipboard (can be pasted to somewhere else).

Select All

Selects all objects on current Workspace.

Select Parent Objects Selects all Parent objects of the currently selected object.
Select Child Objects Selects all Child objects of the currently selected object.
Select Parent and Child objects Selects both Parent and Child objects of the currently selected object.

Find

Opens the Find dialog.

TIP: Use wildcards - example: "*user" or "?ser".

* - replaces unlimited number of characters

? - replaces any single character

Quick Search

Opens Quick Search dialog which allows you to search through all objects in a model.

Select Objects

Allows you to select objects based on their Owner and Category.

 

Related Documents