Chat now with support
Chat with Support

Toad Data Modeler 6.3 - User Guide

Introduction User Interface Models and Model Objects
Physical Data Model
About Physical Data Modeling Benefits of Physical Data Model Entity Relationship Diagram Objects Basic Database Design Advanced Database Design
Universal Data Model Logical Data Model Working with Model Objects Model Properties Model Statistics
Features and Tools
Application Variables Export/Import DDL Script Generation Graphics Model Actions Print Projects Reports Reverse Engineering Scripting and Customization SQL Templates Tips and Tricks Toad for Oracle Integration Toad Intelligence Central (TIC) Integration Tools Version Control
Options and Configuration Databases
Supported Databases Connection Types by Database DB2 UDB v. 8 (LUW) DB2 v. 9 (LUW) DB2 v. 9.5 (LUW) DB2 v. 9.7 (LUW) DB2 v. 10.1 (LUW) DB2 v. 10.5 (LUW) DB2 z/OS v. 9 DB2 z/OS v.10 DB2 z/OS v. 11 Greenplum 4.1 Greenplum 4.2 Ingres 9.3 Ingres 10.0 Microsoft Access 2000/2002/2003 Microsoft Access 2007/2010 Microsoft Azure SQL Database Microsoft Azure SQL Database V12 Microsoft SQL Server 2000 Microsoft SQL Server 2005 Microsoft SQL Server 2008 Microsoft SQL Server 2012 Microsoft SQL Server 2014 Microsoft SQL Server 2016 MySQL 5.0 MySQL 5.1 MySQL 5.5 MySQL 5.6 MySQL 5.7 Oracle 9i Oracle 10g Oracle 11g Release 1 Oracle 11g Release 2 Oracle 12c Release 1 Oracle 12c Release 2 PostgreSQL 8.1 PostgreSQL 8.2 PostgreSQL 8.3 PostgreSQL 8.4 PostgreSQL 9.0 PostgreSQL 9.1 PostgreSQL 9.2 PostgreSQL 9.3 PostgreSQL 9.4 PostgreSQL 9.5 SQLite 3.7 Sybase ASE 12.5 Sybase ASE 15 Sybase ASE 15.5 Sybase ASE 15.7 SAP ASE 16.0 Sybase IQ 15.2 Sybase SQL Anywhere 11 SAP SQL Anywhere 17 Teradata 13 Vertica Database 8.0
Legal Information

Reverse Engineering

Connections

Features and Tools > Reverse Engineering > Connections

To manage database connections

Go to File Menu | Reverse Engineering | Connections.

To create a new database connection

  1. Click New Connection on the toolbar and define a new Connection Name.

  2. Select target database platform.

  3. Select a connection method and specify details.

  4. Select object types you want to work with.

  5. In section Options configure settings used for reverse engineering.

  6. Click Finish to confirm and save the connection.

To test database connection

Select a connection in the Connections dialog and click the Test Connection icon on the toolbar.

Create New Model from Database

Features and Tools > Reverse Engineering > Create New Model from Database

Toad Data Modeler is capable of creating a new model from an existing physical database. By using reverse engineering, you will get an ER diagram of your existing database, which allows you to work more efficiently in the future (e.g. you can make changes in the model and then generate a Change Script to duplicate the changes in your database).

To create a new model

  1. In File Menu | Reverse Engineering open the Connections dialog.
  2. Select an existing connection and click Create New Model from Database.

  3. Select User/Schema and the items you want to reverse engineer. Make sure to go through all tabs containing other object types.

    Note: You may not see all object types, depending on your Connection settings. This can be changed by editing the Connection in Connections dialog and then checking appropriate objects in the What to Reverse dialog.


  4. Click Execute to reverse engineer the database and create a new model.

Open Object Explorer (Live RE)

Features and Tools > Reverse Engineering > Open Object Explorer (Live RE)

Live Reverse Engineering offers an easy and quick way to add database objects from your database to your existing models. Simply use the drag and drop technique and add the objects to a specific Workspace or to Model Explorer.

Note:Before using the Live Reverse Engineering feature, two conditions must be met:

  1. The model you're going to drag and drop database objects to must be of the same database platform and version.
  2. A connection to the database must be already saved and accessible in the Connections dialog (File menu | Reverse Engineering | Connections).
  1. Select a connection to your database and click Open Object Explorer.
  2. Select what entities, views and synonyms you want to add to your model. Use SHIFT for multiple selection.
  3. Drag and drop the selected items from the Object Palette to particular Workspace or Model Explorer.
  4. Close the Object Palette dialog.
Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating