Chat now with support
Chat with Support

Toad Data Modeler 6.3 - User Guide

Introduction User Interface Models and Model Objects
Physical Data Model
About Physical Data Modeling Benefits of Physical Data Model Entity Relationship Diagram Objects Basic Database Design Advanced Database Design
Universal Data Model Logical Data Model Working with Model Objects Model Properties Model Statistics
Features and Tools
Application Variables Export/Import DDL Script Generation Graphics Model Actions Print Projects Reports Reverse Engineering Scripting and Customization SQL Templates Tips and Tricks Toad for Oracle Integration Toad Intelligence Central (TIC) Integration Tools Version Control
Options and Configuration Databases
Supported Databases Connection Types by Database DB2 UDB v. 8 (LUW) DB2 v. 9 (LUW) DB2 v. 9.5 (LUW) DB2 v. 9.7 (LUW) DB2 v. 10.1 (LUW) DB2 v. 10.5 (LUW) DB2 z/OS v. 9 DB2 z/OS v.10 DB2 z/OS v. 11 Greenplum 4.1 Greenplum 4.2 Ingres 9.3 Ingres 10.0 Microsoft Access 2000/2002/2003 Microsoft Access 2007/2010 Microsoft Azure SQL Database Microsoft Azure SQL Database V12 Microsoft SQL Server 2000 Microsoft SQL Server 2005 Microsoft SQL Server 2008 Microsoft SQL Server 2012 Microsoft SQL Server 2014 Microsoft SQL Server 2016 MySQL 5.0 MySQL 5.1 MySQL 5.5 MySQL 5.6 MySQL 5.7 Oracle 9i Oracle 10g Oracle 11g Release 1 Oracle 11g Release 2 Oracle 12c Release 1 Oracle 12c Release 2 PostgreSQL 8.1 PostgreSQL 8.2 PostgreSQL 8.3 PostgreSQL 8.4 PostgreSQL 9.0 PostgreSQL 9.1 PostgreSQL 9.2 PostgreSQL 9.3 PostgreSQL 9.4 PostgreSQL 9.5 SQLite 3.7 Sybase ASE 12.5 Sybase ASE 15 Sybase ASE 15.5 Sybase ASE 15.7 SAP ASE 16.0 Sybase IQ 15.2 Sybase SQL Anywhere 11 SAP SQL Anywhere 17 Teradata 13 Vertica Database 8.0
Legal Information

Object Viewer

User Interface > Interface Layout > Object Viewer

Toad Data Modeler allows you to display a complete list of selected objects of your model, e.g. attributes, triggers, check constraints, views, etc. with a possibility to open the Properties dialog of the selected object(s), delete them or find on the Workspace.

To open Object Viewer

Click on the toolbar.

or

Select Window | Object Viewer....

Object Viewer is docked by default next to the Model Explorer.

Option Description

Object Name

Type an object name (case sensitive).

Object Type

Select a type of object.

Select options for the search process in the checkboxes below.

Click this icon to view the objects.

In the list, you can see:

  • Icon of an object type
  • Physical object name
  • Logical object name
  • Information about parent object
  • Object type (entity, attribute, key, trigger etc.)

Right-click the selected item in the list to display other options (edit, delete, find on Workspace).

Status of Items in Grids

User Interface > Interface Layout > Status of Items in Grids

Various types of status are shown in the following examples of attributes and entities.

  1. Normal state
  2. Attribute Customer ID is being edited. - The item is in grey.
  3. A new attribute has just been added, the change has not been confirmed yet. (After the change is confirmed, the status will change and set to Normal. Until creation of the new item is confirmed, it's not possible to edit it.)
  4. The attribute has been modified in the grid directly (see the changed name). The change has not been confirmed yet.
  5. Item NewAttribute has just been deleted, the change has not been confirmed yet.
  6. Deletion of item NewAttribute has been confirmed by clicking the Apply button. The item is marked as deleted and will not be displayed when you open the Entity Properties form/Attributes tab next time.
  1. You've opened two instances of the same Entity Properties form and started editing properties in one of them. That one will be marked by E and will be editable, while the other form will be marked by n/a and won't be editable.

Note: By default, you can open only one instance of a form. To open more instances at the same time, go to Settings | Options | General | and uncheck the Allow One Instance of Form checkbox.

Menus

File Menu

User Interface > Menus > File Menu

The following options are displayed when there is at least one Designer opened inside the Application Window.

Option Description
New | Project

Creates a new project, displays the New Project settings dialog.

New | Model

Opens the New Model dialog.

Supported models:

  • Physical Data Model
  • Universal Data Model
  • Logical Data Model

TIP: Right-click the dialog to select the display of the options (Large Icons, Small Icons, List).

 

Model Name -  Define a name of your model. (Also, you can change the name later in the Application View or Model Explorer (press F2).)

 

Notes:

Note:

  • Database Name - A database for which the model has been created  (e.g. Oracle 10g). The database name information can be found at the bottom of the Application Window, or it is displayed in the pop-up hint when you point your mouse cursor at the Model Name in the Application View or Model Explorer.
  • Model Name - In Toad Data Modeler, Model Name should be understood as a title of a document that is saved.
  • File Name - A name of file under which the model is saved. File Name is defined after you select Save Model or Save Model as.

New | Gallery

Opens the Gallery Edit dialog.

You can create Gallery to store frequently used parts of your models such as entities, attributes, stored procedures and other objects. You can then access these parts from any project.

Open | Project

Displays the Open dialog in your default Projects folder.

Open | Model Displays the Open dialog in your default Models folder.

Open | Samples

Displays the Open dialog in your default Samples folder.
Open | Gallery Displays the Open dialog in your default Gallery folder.
Open | Sample Gallery Displays the Open dialog in your default Sample Gallery folder.

Recent Files

Contains a list of recently opened files.

Save Model

Saves opened model or opens the Save file dialog.

Save Model as

Opens the Save file dialog and allows you to save your model to another folder or in another file format.

Reverse Engineering | Connections

Opens the Connections dialog.

Reverse Engineering |
Reverse Engineering Wizard

Opens the Reverse EngineeringWizard.

Import | Toad for Oracle Project

Displays the Open dialog in you default Toad Data Modeler folder.

Import | Toad for Oracle ERD Displays the Open dialog in your default Toad Data Modeler folder and also opens Connections dialog.
Import | Case Studio 2 Model Displays the Open dialog in your default Models folder. This option is used for importing model files from Case Studio 2.
Import | Import from Excel Opens the Import from Excel dialog.
Import | Import from CSV Opens the Import from CSV dialog.
Export | Export to Excel Opens the Export to Excel dialog.

Export | Export to CSV

Opens the Export to CSV dialog.

Export | Export to Image

Opens the Export to Image dialog.

Close | Model

Closes currently selected model.

Close | All Models Closes all opened models.

Page Setup

Opens the Page Setup dialog.

Print Preview

Displays a preview of your ER diagram as it will look when printed.

Print

Opens the Print dialog to configure printer settings.

Exit

Finishes your work in Toad Data Modeler. Before closing the application your are asked to save changes you made in your models.

This is done in the Application Close dialog (shown on the screenshot below), where all of your opened models and projects are listed. Select all the items that you want to save, all items that have been modified are selected to be saved by default.

Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating