Chat now with support
Chat with Support

Toad Data Modeler 6.3 - User Guide

Introduction User Interface Models and Model Objects
Physical Data Model
About Physical Data Modeling Benefits of Physical Data Model Entity Relationship Diagram Objects Basic Database Design Advanced Database Design
Universal Data Model Logical Data Model Working with Model Objects Model Properties Model Statistics
Features and Tools
Application Variables Export/Import DDL Script Generation Graphics Model Actions Print Projects Reports Reverse Engineering Scripting and Customization SQL Templates Tips and Tricks Toad for Oracle Integration Toad Intelligence Central (TIC) Integration Tools Version Control
Options and Configuration Databases
Supported Databases Connection Types by Database DB2 UDB v. 8 (LUW) DB2 v. 9 (LUW) DB2 v. 9.5 (LUW) DB2 v. 9.7 (LUW) DB2 v. 10.1 (LUW) DB2 v. 10.5 (LUW) DB2 z/OS v. 9 DB2 z/OS v.10 DB2 z/OS v. 11 Greenplum 4.1 Greenplum 4.2 Ingres 9.3 Ingres 10.0 Microsoft Access 2000/2002/2003 Microsoft Access 2007/2010 Microsoft Azure SQL Database Microsoft Azure SQL Database V12 Microsoft SQL Server 2000 Microsoft SQL Server 2005 Microsoft SQL Server 2008 Microsoft SQL Server 2012 Microsoft SQL Server 2014 Microsoft SQL Server 2016 MySQL 5.0 MySQL 5.1 MySQL 5.5 MySQL 5.6 MySQL 5.7 Oracle 9i Oracle 10g Oracle 11g Release 1 Oracle 11g Release 2 Oracle 12c Release 1 Oracle 12c Release 2 PostgreSQL 8.1 PostgreSQL 8.2 PostgreSQL 8.3 PostgreSQL 8.4 PostgreSQL 9.0 PostgreSQL 9.1 PostgreSQL 9.2 PostgreSQL 9.3 PostgreSQL 9.4 PostgreSQL 9.5 SQLite 3.7 Sybase ASE 12.5 Sybase ASE 15 Sybase ASE 15.5 Sybase ASE 15.7 SAP ASE 16.0 Sybase IQ 15.2 Sybase SQL Anywhere 11 SAP SQL Anywhere 17 Teradata 13 Vertica Database 8.0
Legal Information

Format Workspaces and Objects

Features and Tools > Graphics > Format Workspaces and Objects

You can set format for all Workspaces of your model, for each Workspace separately and also for particular objects.

To set format for new models (models that you will create)

  1. Select Settings | Options | Model section | Physical/Logical Model.
  2. Define options on tabs Workspace, Shape, Note Line and Entity.
  3. Press CTRL+N to create a new model.

To change format of objects in existing models

Right-click the Workspace and select Workspace Format.

To change format of a particular object

Right-click the object on the Workspace and select Format.

Note: If you need to preserve format of a particular object against changes of format of your WS, select the Lock Format option in the Object Format dialog | General tab.

Line Autolayout

Features and Tools > Graphics > Line Autolayout

Toad Data Modeler provides you with an useful tool that is capable of automatically organizing your lines in your model diagram.

How to use Line Autolayout

  1. On workspace select lines which you want to organize (or don't select any to organize all lines).
  2. Go to Layout Menu | Line Autolayout or click on Layout Toolbar.

  3. Line Autolayout dialog displays. You can now customize its settings.

Option Description
Speed Settings

Line Autolayout function tries to find the most optimal result from a set generated number of line variations. Generally, the more variants, the better the result and the more time Line Autolayout takes.

You can select the Simple option and use the slider to set the number of generated variations. Or select the Custom option and enter the maximum number of calculated variants manually.

Note that the bigger the number of variants and shapes on workspace is, the more time the process takes.

Minimal Distance Between Lines

Determines the distance between lines on a shape edge.

Cross Lines When checked, variants where lines are crossed are preferred.
Straight Lines When checked, variants where lines are straight are preferred.

Line Autolayout settings

Go to Settings Menu | Options | Graphics | Autolayout tab.

In LinesAutolayout section you can define the default settings of Line Autolayout function.

Set Colors for Attributes and Keys

Features and Tools > Graphics > Set Colors for Attributes and Keys

To define different colors for attributes on your Workspace

Select Settings | Options | Model section | Physical Model/Logical Model| Entity tab | Attribute Colors area.

TIP: When you point your mouse cursor at a relationship line, parent and child attributes are highlighted on the Workspace. You can set the color at: Settings | Options | Graphics | Colors area | Highlight Color.

Grid and Grid Size

Features and Tools > Graphics > Grid and Grid Size

The Grid options are available directly from the toolbar or from the View menu.

To show grid and set a grid size

  1. Click to show grid.
  2. To change a grid size, click .
  3. To snap objects of your ERD to grid, click .
Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating