Chat now with support
Chat with Support

Toad Data Modeler 6.2 - User Guide

Introduction User Interface Models and Model Objects
Physical Data Model
About Physical Data Modeling Benefits of Physical Data Model Entity Relationship Diagram Objects Basic Database Design Advanced Database Design
Universal Data Model Logical Data Model Working with Model Objects Model Properties Model Statistics
Features and Tools
Application Variables Export/Import DDL Script Generation Graphics Model Actions Print Projects Reports Reverse Engineering Scripting and Customization SQL Templates Tips and Tricks Toad for Oracle Integration Toad Intelligence Central (TIC) Integration Tools Version Control
Options and Configuration Databases
Supported Databases Connection Types by Database DB2 UDB v. 8 (LUW) DB2 v. 9 (LUW) DB2 v. 9.5 (LUW) DB2 v. 9.7 (LUW) DB2 v. 10.1 (LUW) DB2 v. 10.5 (LUW) DB2 z/OS v. 9 DB2 z/OS v.10 DB2 z/OS v. 11 Greenplum 4.1 Greenplum 4.2 Ingres 9.3 Ingres 10.0 Microsoft Access 2000/2002/2003 Microsoft Access 2007/2010 Microsoft Azure SQL Database Microsoft Azure SQL Database V12 Microsoft SQL Server 2000 Microsoft SQL Server 2005 Microsoft SQL Server 2008 Microsoft SQL Server 2012 Microsoft SQL Server 2014 Microsoft SQL Server 2016 MySQL 5.0 MySQL 5.1 MySQL 5.5 MySQL 5.6 MySQL 5.7 Oracle 9i Oracle 10g Oracle 11g Release 1 Oracle 11g Release 2 Oracle 12c Release 1 Oracle 12c Release 2 PostgreSQL 8.1 PostgreSQL 8.2 PostgreSQL 8.3 PostgreSQL 8.4 PostgreSQL 9.0 PostgreSQL 9.1 PostgreSQL 9.2 PostgreSQL 9.3 PostgreSQL 9.4 PostgreSQL 9.5 SQLite 3.7 Sybase ASE 12.5 Sybase ASE 15 Sybase ASE 15.5 Sybase ASE 15.7 SAP ASE 16.0 Sybase IQ 15.2 Sybase SQL Anywhere 11 SAP SQL Anywhere 17 Teradata 13 Vertica Database 8.0
Legal Information

Gallery

Basic Actions

Features and Tools > Tools > Gallery > Basic Actions

Toad Data Modeler allows you to reuse frequently used parts of your model, no matter if they are entities, single attributes, stored procedures or other objects. This can be done using Gallery where you can simply drag and drop items from your models and use them in your other models.

Some basic Gallery actions include:

  • Creating a new Gallery
  • Adding objects to a Gallery
  • Inserting objects to a Model
Creating a new Gallery
  1. Go to File Menu and select New | Gallery.

  2. Choose the Gallery Name, enter its Description and choose whether you want to comment out code of database specific objects (this option is explained in the Inserting objects... section).

  3. Your Gallery will be opened in the Gallery Explorer.

Adding new objects to a Gallery
  1. To add a new object to a Gallery, simply drag it from Workspace or Model Explorer to and drop it on the Gallery name in Gallery Explorer.

  2. Your object is now part of the Gallery and you can view its properties by expanding it.

Inserting objects to a Model
  1. If you have one or more objects stored in Gallery, you can insert them into a model by simply dragging them to workspace.

Note: If the model database of the object is different from the target model database (e.g. Entity created in Oracle 10g model dragged to SQL Server 2010 model), it will be converted. Note that database-specific properties (mainly SQL code) may be syntactically invalid in the target database. If you have enabled the Comment out code from database specific objects... option, the properties will be commented out and you can fix their syntax later.

Note: You have to drag and drop the main node of the object in the Gallery to actually move the object, not any of its child nodes.

Gallery Explorer

Features and Tools > Tools > Gallery > Gallery Explorer

This windows is capable of displaying all of your Galleries and their objects and it also allows you to change their structure.

The Explorer toolbar contains several options:

Option Description
New Gallery Creates a new Gallery as described in Basic Actions.
Open Gallery Opens an existing Gallery file (.txgall file format)
Save Gallery Saves recent changes made to Gallery.
Properties Displays Gallery Properties - Name, Decription, Path.
New Folder

Creates a new folder in the Gallery.

Delete Selected Item

Deleted the selected object.

Close Gallery Closes (not deletes) the selected Gallery.

Items in the Explorer also have the following unique right-click options:

Option Description
Save as (Gallery) Allows you to save Gallery as a .txgall file to the selected location.
Item properties (Item) Allows you to modify item properties (Name, Author, Descriptio) and view its objects.
Modify (Item) Allows you to modify the stored item in a separate model and synchronize the changes with the item in the Gallery. See Modifying Items for more information.

Modifying Items

Features and Tools > Tools > Gallery > Modifying Items

Items in Gallery can be easily modified in a temporary model and the changes can be saved immediately.

  1. In Gallery Explorer, open your Gallery, right-click the item(s) you wish to modify and select Modify....

  2. The item(s) will be placed into a temporary model and you will be able to modify them. The exact way to modify the items varies depending on the number of objects and whether they are shortcuts or not:
    • One object (not shortcut) - the Properties dialog of the objects will be opened right away.
      Example - Entity added to a Gallery by dragging it from Model Explorer.
    • One object (a shortcut) - the object will be shown on workspace, you can view and change its Properties.
      Example - Entity added to a Gallery by dragging it from Workspace.
    • Multiple objects (not shortcuts) - no Properties dialog or Workspace will be shown, you will have to open Properties by locating the object in Model Explorer.
      Example - Two entities added to a Gallery at once by dragging them from Model Explorer.
    • Multiple objects (shortcuts) - the objects will be shown on Workspace, you can view and change their Properties.
      Example - Two entities added to a Gallery at once by dragging them from Model Explorer.
  3. One way or another, you should be able to modify the item(s) as you need. Once you're done, click the Save to Gallery button on File Toolbar.

  4. In the opened dialog, you can choose if you want to save the changes made to the modified item and its related items.

 

 

 

 

Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating