Chat now with support
Chat with Support

Toad Data Modeler 6.2 - User Guide

Introduction User Interface Models and Model Objects
Physical Data Model
About Physical Data Modeling Benefits of Physical Data Model Entity Relationship Diagram Objects Basic Database Design Advanced Database Design
Universal Data Model Logical Data Model Working with Model Objects Model Properties Model Statistics
Features and Tools
Application Variables Export/Import DDL Script Generation Graphics Model Actions Print Projects Reports Reverse Engineering Scripting and Customization SQL Templates Tips and Tricks Toad for Oracle Integration Toad Intelligence Central (TIC) Integration Tools Version Control
Options and Configuration Databases
Supported Databases Connection Types by Database DB2 UDB v. 8 (LUW) DB2 v. 9 (LUW) DB2 v. 9.5 (LUW) DB2 v. 9.7 (LUW) DB2 v. 10.1 (LUW) DB2 v. 10.5 (LUW) DB2 z/OS v. 9 DB2 z/OS v.10 DB2 z/OS v. 11 Greenplum 4.1 Greenplum 4.2 Ingres 9.3 Ingres 10.0 Microsoft Access 2000/2002/2003 Microsoft Access 2007/2010 Microsoft Azure SQL Database Microsoft Azure SQL Database V12 Microsoft SQL Server 2000 Microsoft SQL Server 2005 Microsoft SQL Server 2008 Microsoft SQL Server 2012 Microsoft SQL Server 2014 Microsoft SQL Server 2016 MySQL 5.0 MySQL 5.1 MySQL 5.5 MySQL 5.6 MySQL 5.7 Oracle 9i Oracle 10g Oracle 11g Release 1 Oracle 11g Release 2 Oracle 12c Release 1 Oracle 12c Release 2 PostgreSQL 8.1 PostgreSQL 8.2 PostgreSQL 8.3 PostgreSQL 8.4 PostgreSQL 9.0 PostgreSQL 9.1 PostgreSQL 9.2 PostgreSQL 9.3 PostgreSQL 9.4 PostgreSQL 9.5 SQLite 3.7 Sybase ASE 12.5 Sybase ASE 15 Sybase ASE 15.5 Sybase ASE 15.7 SAP ASE 16.0 Sybase IQ 15.2 Sybase SQL Anywhere 11 SAP SQL Anywhere 17 Teradata 13 Vertica Database 8.0
Legal Information

Settings Menu

User Interface > Menus > Settings Menu

Option Description
Options Displays the Options dialog, where most of the Toad Data Modeler settings are located.
Add/Remove Databases Opens a dialog where you can enable/disable installed databases.
Reset to Default Layout Resets the application layout to default, requires restart.
Default Values Allows you to set various default properties (e.g. Names, Captions, Values).
Templates Displays the Template Editor where you can add or edit your own templates. These can be used when editing SQL code of some objects.
Dictionaries Contains terms used in generated reports. Feel free to add your own new terms, export/import dictionaries or translate them to another language.
 

Window Menu

User Interface > Menus > Window Menu

Window Menu is a basic access point for displaying dockable windows, panes and toolbars.

Option Description
Toolbars Used to show/hide all available toolbars.
Application View Shows/hides Application View window.
Model Explorer Opens an instance of Model Explorer window.
Object Viewer Opens an instance of Object Viewer window.
Model Actions Opens Model Actions window.
Align Pallete Opens Align Palette where you can click buttons to align selected objects on workspace.
Loupe Shows/hides Loupe window.
Overview Shows/hides Overview window.
Message Explorer Log

Opens an instance of Message Explorer window.

Verification Log Opens an instance of Verification Log window.

Help Menu

User Interface > Menus > Help Menu

Through the Help menu you can access many helpful resources (such as product documentation, Toad Web Site, community page on ToadWorld.com...) and manage Licenses for Toad Data Modeler.

 

Search Bar

User Interface > Menus > Search Bar

Using Search Bar you can easily search for a term in multiple destinations, such as Help, ToadWorld.com and the Internet.

Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating