Chat now with support
Chat with Support

Toad Data Modeler 6.2 - User Guide

Introduction User Interface Models and Model Objects
Physical Data Model
About Physical Data Modeling Benefits of Physical Data Model Entity Relationship Diagram Objects Basic Database Design Advanced Database Design
Universal Data Model Logical Data Model Working with Model Objects Model Properties Model Statistics
Features and Tools
Application Variables Export/Import DDL Script Generation Graphics Model Actions Print Projects Reports Reverse Engineering Scripting and Customization SQL Templates Tips and Tricks Toad for Oracle Integration Toad Intelligence Central (TIC) Integration Tools Version Control
Options and Configuration Databases
Supported Databases Connection Types by Database DB2 UDB v. 8 (LUW) DB2 v. 9 (LUW) DB2 v. 9.5 (LUW) DB2 v. 9.7 (LUW) DB2 v. 10.1 (LUW) DB2 v. 10.5 (LUW) DB2 z/OS v. 9 DB2 z/OS v.10 DB2 z/OS v. 11 Greenplum 4.1 Greenplum 4.2 Ingres 9.3 Ingres 10.0 Microsoft Access 2000/2002/2003 Microsoft Access 2007/2010 Microsoft Azure SQL Database Microsoft Azure SQL Database V12 Microsoft SQL Server 2000 Microsoft SQL Server 2005 Microsoft SQL Server 2008 Microsoft SQL Server 2012 Microsoft SQL Server 2014 Microsoft SQL Server 2016 MySQL 5.0 MySQL 5.1 MySQL 5.5 MySQL 5.6 MySQL 5.7 Oracle 9i Oracle 10g Oracle 11g Release 1 Oracle 11g Release 2 Oracle 12c Release 1 Oracle 12c Release 2 PostgreSQL 8.1 PostgreSQL 8.2 PostgreSQL 8.3 PostgreSQL 8.4 PostgreSQL 9.0 PostgreSQL 9.1 PostgreSQL 9.2 PostgreSQL 9.3 PostgreSQL 9.4 PostgreSQL 9.5 SQLite 3.7 Sybase ASE 12.5 Sybase ASE 15 Sybase ASE 15.5 Sybase ASE 15.7 SAP ASE 16.0 Sybase IQ 15.2 Sybase SQL Anywhere 11 SAP SQL Anywhere 17 Teradata 13 Vertica Database 8.0
Legal Information

Export/Import CSV

Features and Tools > Export/Import > Export/Import CSV

Toad Data Modeler allows you to export metadata to a CSV file. Comments, notes and other properties can be modified and the the file can be then imported back into Toad Data Modeler.

To export your model to a CSV file

  1. Select File | Export | Export to CSV.
  2. Select the entities and relationships you want to export.
  3. Click Export. A new CSV file will be created in the specified destination.

To import the data from a CSV file

  1. Select File Menu | Import | Import from Excel.
  2. Locate the CSV file and click Open.
  3. Select which tables and relationships should be imported.

  4. Click Import. The existing model will be updated to reflect the changes made in the CSV file.

Export to Image

Features and Tools > Export/Import > Export to Image

In Toad Data Modeler, you can export your ER diagram into the following graphical formats:

  • BMP
  • JPEG
  • PNG

To export your ER diagram to a graphic file

  1. Select File Menu| Export | Export to Image.
  2. Define options on Settings tab.
Option Description

File Type

Choose one of the three available formats.

Color

When not enabled, the image will be black and white only.

Pages

Creates an image for each page on workspace.

Paint Frame of Pages

Displays page boundaries

Scale

Size of the output in percentage scale (Initial value is 100 per cent.)

Width

Changes automatically according to the set percentage scale.

Height

Changes automatically according to the set percentage scale.

Margin

Set Margin for the exported graphics.

TIP: Measurement units can be changes in Settings Menu | Options | General.

Destination File

The output image destination path.

Open Folder After Export When checked, the destination folder is opened once the export is finished.
  1. Define other settings specific to the selected graphical format on other tabs.

NOTE: Images of large models are generated as multiple smaller ones joined together in a html file.

Export to Image Limitations

Please note that there is a limit to the site of the exported images imposed by Windows interface. The maximum size depends on chosen Pixel Format, for 32-bit, the size limit is about 12500x10000 px. The lower the Pixel Format, the larger image you are able to export. This limitation affects all image formats.

 

 

Import from ER/Studio Data Architect

Features and Tools > Export/Import > Import from ER/Studio Data Architect
  • Toad Data Modeler is able to import physical models for Oracle versions 9, 10, 11, and 12
  • ER/Studio Data Architect needs to be installed in order to import physical models into Toad Data Modeler
  • Select File | Import | ER/Studio Data Architect to import models

DDL Script Generation

Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating