Chat now with support
Chat with Support

Spotlight on Oracle 10.10 - Release Notes

Manual Oracle User Installation Scripts

Overview

This is the basic process that you should follow when using the manual installation scripts.

  1. Run install_post11gr2.sql to get the basic user setup.
  2. Additionally, run ppcm_install_post11gr2.sql to create the Predictive Diagnostics objects and enable Spotlight's predictive capabilities.

Note: For Oracle versions prior to 11g Release 2 there are the equivalent files install_pre11gr2.sql and ppcm_install_pre11gr2.sql.

 

User Scripts

There are two scripts that allow you to use SQL*Plus to manually install the Spotlight on Oracle user into a target database. It replicates core functionality that is available through the Spotlight Oracle User Wizard.

The two User scripts (located in the Plug-ins\SoO\OracleScripts sub-folder of the Spotlight installation folder) are:

  • Install_post11gr2.sql - Creates a new user and installs Spotlight objects into this schema.
  • Upgrade_post11gr2.sql - Relies on an existing database user to install Spotlight objects.

Note: For Oracle versions prior to 11g Release 2 there are the equivalent files install_pre11gr2.sql and upgrade_pre11gr2.sql.

 

Predictive Diagnostics Scripts

Spotlight Predictive Diagnostics can also be installed through manual scripts. The scripts that we have included allow you to install Predictive Diagnostics into a separate schema to the Spotlight user, or (if there are multiple Spotlight users) to create synonyms for a second Spotlight user so it can use an existing installation of Predictive Diagnostics.

The Predictive Diagnostics scripts (located in the Plug-ins\Ppcm\OracleScripts sub-folder of the Spotlight installation folder) are:

  • Ppcm_install_post11gr2.sql - Creates a Predictive Diagnostics object.
  • Ppcm_synonym.sql - Creates synonyms to an existing Predictive Diagnostics-enabled schema.
  • Ppcm_upgrade_post11gr2.sql – Upgrades an older version of Predictive Diagnostics.

Note: For Oracle versions prior to 11g Release 2 there are the equivalent files Ppcm_install_pre11gr2.sql and Ppcm_upgrade_pre11gr2.sql.

 

A note on Predictive Diagnostics

In the Predictive Diagnostics scripts, Impending Bottlenecks and Performance Modelling are installed only if the database version is 10.2 or later. For earlier versions, Degrading SQL is the only predictive capability installed.

Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating