Chat now with support
Chat with Support

SharePlex 9.0.1 - Upgrade Guide

Basic system requirements

Before installing SharePlex, ensure that your system meets the minimum hardware and software requirements.

  • SharePlex processes are all 64-bit and can exceed 4 GB.
  • Per process memory of greater than or equal to 256 MB is required.
  • See the Preinstallation Checklist in the SharePlex Installation Guide for additional system and/or database requirements.

Internet protocol

SharePlex supports both IPv4 and IPv6 internet protocol. The following table shows the platforms for which SharePlex was tested with IPv6.

Platform

Source

Target

SharePlex Source
and Target versions

On-premise/Cloud

Linux RHEL

Link-Local IPV6

Link-Local IPV6

9.0 - 9.0

On-premise

Linux RHEL

Link-Local IPV6

Link-Local IPV6

8.6.5 - 9.0

On-premise

Linux RHEL

Link-Local IPV6

Link-Local IPV6

9.0 - 8.6

On-premise

Linux Suse

Link-Local IPV6

Link-Local IPV6

9.0 - 9.0

On-premise

Windows

Link-Local IPV6

Link-Local IPV6

9.0 - 9.0

On-premise

Windows

Link-Local IPV6

Link-Local IPV6

9.0 - 8.6.4

On-premise

HP UA

Link-Local IPV6

Link-Local IPV6

9.0 - 9.0

On-premise

HP IA

Link-Local IPV6

Link-Local IPV6

9.0 - 9.0

On-premise

SUN Sprac

Link-Local IPV6

Link-Local IPV6

9.0 - 9.0

On-premise

SUN Solaris

Link-Local IPV6

Link-Local IPV6

9.0 - 9.0

On-premise

AIX

Link-Local IPV6

Link-Local IPV6

9.0 - 9.0

On-premise

Linux RHEL

Public IPV6

Public IPV6

9.0 - 9.0

Cloud

Windows

Public IPV6

Public IPV6

9.0 - 9.0

Cloud

Interoperability between versions

Refer to the following guidelines if the system where you are installing the current version of SharePlex is in a configuration where one or more other systems will continue to use an older version. An example would be where you are installing or upgrading SharePlex on a target, but the source will continue to use SharePlex 8.5 or earlier.

Versions with full interoperability

The following SharePlex versions are fully interoperable, including the Compare/Repair feature:

8.0.x

8.5.x

8.6.x

9.0.x

To support replication from a higher to a lower version, set the SP_SYS_TARGET_COMPATIBILITY parameter on the source system to the lower SharePlex version. If Capture is running, restart it.

Important: Downgrading from a higher to a lower version of SharePlex is not supported.

Notes:

  • The older version of the SP_SYS_TARGET_COMPATIBILITY parameter, SP_OCT_TARGET_COMPATIBILITY, has been deprecated in version 9.0. If your source SharePlex is currently replicating to a lower SharePlex version on the target and you have SP_OCT_TARGET_COMPATIBILITY set to the lower version, SharePlex will continue to use that value after you upgrade to version 9.0.
  • If you upgrade the target to the current release at a future time, issue a reset for SP_OCT_TARGET_COMPATIBILITY on the source system to remove it from the SharePlex environment. Going forward, SharePlex will use the setting of the new SP_SYS_TARGET_COMPATIBILITY parameter, which defaults to the current version.

To reset SP_OCT_TARGET_COMPATIBILITY

  1. Stop Capture.

    sp_ctrl>stop capture

  2. In sp_ctrl on the source system, issue the following command:

    sp_ctrl> reset param SP_OCT_TARGET_COMPATIBILITY

  3. Restart Capture.

    sp_ctrl> start capture

Supported data stores

Data Store Type of Support Version Driver version
Apache Kafka target .08 and later

N/A

Note: A Kafka target is supported on Red Hat Linux version 6.0 or later.

Flat file - SQL output target N/A N/A
Flat file - XML output target N/A N/A
JMS - ActiveMQ target 5.8 N/A
JMS - IBM MQ target 7.x and 8.x N/A

Microsoft SQL Server

source and target

2012

2014

2016

Note: Supported as a source only on Windows 2012 R2.

Microsoft SQL Server ODBC Driver

Do not use the Microsoft SQL Server Native Client. SharePlex will return an error during setup if the correct driver is not used. To tell the difference between the two:

  • The Microsoft SQL Server ODBC Driver has versions such as 06.02.9200.
  • The Microsoft SQL Server Native Client has versions such as 11.00.3513.
MySQL target 5.6 and later ODBC driver version 5.3.2 or later.
Oracle Database (64-bit only)

source and target

10g R1 and R2

11g R1 and R2

12cR1 and R2

N/A
PostgreSQL*

(Symfoware Server, EDB Postgres Advanced Server, others)

target 9.4 and later*

Use the driver version that is recommended by the vendor of the PostgreSQL implementation that you are using.

SAP Adaptive Server Enterprise (ASE) target 15.7 N/A
SAP HANA target 1.0 SPS 11 Rev111 HDBODBC or HDBODBC32 driver provided with the HANA database installation.
Teradata target 15.00.03.05 Teradata ODBC driver version 15.10.00.01 or later

* SharePlex supports all implementations of the PostgreSQL open source object-relational database system.

Cloud support

The following shows the configurations that SharePlex supports when either the source or target, or both, are cloud-based databases.

Source To Target
Oracle on EC2 Linux

Oracle on AWS EC2 Linux

   
Oracle on Azure Linux

Oracle on Azure Linux

   
Oracle on on-premise Linux
  • Oracle on AWS RDS
  • Oracle on AWS EC2
  • PostgreSQL (Community) on Azure Linux
  • PostgreSQL (Community) on AWS EC2

  • PostgreSQL (Community) on AWS RDS

  • EDB Postgres Advanced Server on AWS EC2
  • EDB Postgres Advanced Server on Azure Linux
  • Fujitsu Symfoware Server on AWS EC2
  • Fujitsu Symfoware Server on Azure Linux
  • MySQL on AWS EC2
  • MySQL on AWS RDS
  • MySQL on Azure Linux
  • Aurora on AWS RDS
  • SQL Server on AWS EC2
  • SQL Server on AWS RDS
  • SQL Server on Azure Windows (IaaS)
  • SQL Server on Azure Windows (PaaS)
   
SQL Server on on-premise Windows
  • SQL Server on Azure Windows
  • SQL Server on EC2 Windows
Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating