Chat now with support
Chat with Support

Migrator for Notes to Exchange 4.16 - Administration Guide

About the Migrator for Notes to Exchange documentation Notes Migration Manager NABS Discovery Wizard Internet Domains Discovery Wizard Directory Export Wizard Collection Wizard Groups Provisioning Wizard Notes Data Locator Wizard Provisioning Wizard Send PAB Replicator Wizard Data Migration Wizard SSDM Statistics Collection Wizard The Log Viewer Using the Qsched.exe task-scheduling utility SSDM Scheduling Administration utility Office 365 Admin Account Pool utility PowerShell cmdlets for Migrator for Notes to Exchange Appendix A: How do I ...?
Post-installation configuration Pre-migration preparations Batch-migration process Other features

Help menu

Online Help... (or F1): Opens Quest’s online Help file for the Log Viewer, which documents its features.
About...: Opens a window of information about the Log Viewer—identifying the current release, and asserting Quest’s intellectual property rights to the software.

How to ...

This section describes how to accomplish various tasks in the Log Viewer.

Click the Open Log File button (in the Toolbar) to view a list of log files that can be opened. In the File section of the screen, select a log file and click OK to open the log in the Quest Log File Viewer.
Edit menu | Find... (or Ctrl+F): Opens a Find dialog box that lets you specify a text string to search for within the open file. The Find feature highlights the entire line that contains the target string.
File menu | Recent Files: Shows a list of recently opened files, from which you can select a file to re-open (to quickly re-open a file you have recently viewed and closed).
File menu | Save Copy Of Log File As... (appears only when a file is open): Opens a standard Windows Save As dialog box, from which you can specify the filename and location where you want the open file to be saved. (This feature does not permit any revisions to the open file. It simply lets you save the file in its original form to a new filename and/or a new location.)
View menu | Show Line Numbers (or Ctrl+L): Toggles the display of line numbers (within the open file) on and off.
Edit menu | Go To Line Number: Opens a dialog box that lets you specify the destination line number. (Enter the number and click OK.)
View menu | Show Complete Log Entry (or F5): Opens a Log Detail window that shows the entire string for the selected item—useful when the item text overruns the Log Viewer’s maximum line length (maximum 259 characters), or if the line extends beyond the right edge of the viewer window without wrapping.
View menu | Enable Internet Access: Toggles the Internet connection on and off.
Edit menu | Copy (or Ctrl+C): Copies the selected line to the Windows clipboard.
File menu | Exit: Closes the Log Viewer window, or click the Log Viewer Close box ([X]) to dismiss the window and return to the previous display.

Using the Qsched.exe task-scheduling utility

Using the Qsched.exe task-scheduling utility

The Migrator for Notes to Exchange (MNE) wizards are used to define the tasks that run migrations. Many wizards let you schedule tasks to run at certain times on certain days. Using the Manage Scheduled Operations screen in the Notes Migration Manager, you can revise the task-execution schedules. However, the wizards and Manage Scheduled Operations screen only manage the scheduling of task runs and these schedules are saved in the SQL database.

The scheduled tasks are executed by a low level Migrator for Notes to Exchange Task Scheduler utility called qsched.exe which is located in the Migrator for Notes to Exchange installation directory. This utility is controlled by the MNE Task Schedule service.

The name of the task scheduler service is “Quest Migrator for Notes to Exchange Task Scheduler” and it is automatically installed when you install MNE. By default, the task scheduler service is configured to be in the disabled state. The service is installed to run as Local System.

You can manage the task scheduler service as you would any other Windows service using the Windows Service Manager. Instructions for configuring a Windows service can be found at: http://msdn.microsoft.com/en-us/library/ms681921(v=vs.85).aspx.

When used, the task scheduler service polls the Migrator for Notes to Exchange database at regular intervals for any scheduled tasks and invokes the qsched.exe utility to run those tasks at the designated times.

Post-installation configuration

After installing MNE, there are additional configuration steps required to use the Migrator for Notes to Exchange Task Scheduler utility. Open the Windows Service Manager and complete the following steps:

Related Documents