Chat now with support
Chat with Support

Metalogix Content Matrix 8.8 - Public Folder Editon User Guide

Introduction Entering the License Key Content Matrix Console End User Interface Installing the Email Viewer Webpart Connecting to Public Folders Connecting to SharePoint Preparing for Your Migration Configuring Copying Options Saving or Running a Migration Action Log Files Using PowerShell with Content Matrix Modifying Content Matrix Configuration and Settings Frequently Asked Questions About Us

Saving or Running a Migration Action

When you finish configuring a migration action, you can run it immediately or save a copy of the settings to a job file, which displays in the Job List section.  You can then:

· run a migration directly from the Jobs List section

OR

·schedule the job to run at a specified time, either as a Windows Scheduled Task or straight from PowerShell.

OR

·If the Console is configured as the Controller (Host) machine for Distributed Migration, submit a Distributed Migration job.

You can also save the job configuration as a template so that you can preserve and reuse settings for future migration jobs.

When the migration starts, a status dialog box will appear. The migration logs can be viewed (in progress or after the migration is finished) by clicking [Details>>]. The Status section of the status box will list a live count for the number of successes, warnings, failures, etc. for the migration. The Progress section of this dialog will list any completions and the type of completion (Sites, lists, items, users, groups, etc.). A Migration Completed message will appear when finished. Click Close to exit the status dialog.

Importing and Exporting Migration Jobs

From the Jobs List, you can export a job to an xml file.  This functionality allows you to:

·Copy a job from one instance of Metalogix Content Matrix to another (as long they are for the same Edition).

·Manually modify a job, then re-import it.

To export a job to an xml file:

1.In the Job List, select the job you want to export.

2.Right-click, and choose Export selected job to xml.

The xml file will automatically open in whatever program is set as the default application for xml files, and it can be saved to any desired location.

To import an xml file to the Job List:

1.Make sure the file you want to import uses a different ID value than any existing Jobs (this should only be an issue if the XML file was previously exported from the same Metalogix Content Matrix Console).

NOTE: If the xml file that is being imported contains the same ID value as an already existing Job, then the import will fail.

2.From the Job List menu, choose File > Import Jobs From Xml.

3.Select the xml file to import.

If the import is successful, the job will be listed in the Job List section.  If unsuccessful, an error message will be given.

Saving a Job Configuration as a Template

You can create job configuration templates for a set of selected settings which can be saved and reused, including any options that are not normally preserved using the Preserve Configuration Options option (in the ribbon Settings menu).

These templates can also be moved to another machine and used with a separate install of Metalogix Content Matrix Console (provided that it is the same Edition of Metalogix Content Matrix, and the same version number or greater).

To save a job configuration template:

1.After initiating a migration, complete the Configure (Object) Copying Options with the settings that you want to include in the template.

Sve Job Configuration dialog

2.Click [Save Job Configuration].

Here you can set the display name for the job template. This is not the actual file name, but it is the name that Metalogix Content Matrix will use to list the template.

NOTE: In most cases, when a job template is saved by Metalogix Content Matrix it will be saved to the following location:

<Drive>:\Users\<User>\AppData\Roaming\Metalogix\Metalogix Content Matrix Console - <Product> Edition

However, it is highly recommended that you do not interact with this system location. If you are trying to save a job template so it can be exported to another system the template can be exported from the Manage Job Configurations dialog.

3.Enter the desired display name value and click [OK] to continue.

Once the save is complete, you will be returned to the Configure <Object> Copying Options dialog where the migration can either be Run or Saved.

The saved job templates will now be visible in the Manage Job Configurations dialog.

NOTE: If you are looking to save a job template and move it to another system for use, this should be done using the Export option in the Manage Job Configurations window. Additionally, if you are trying to Import a job template from another system, this must also be done from either the Manage Job Configurations dialog or it can be imported when applying a template.

Applying a Job Template

Any job templates that have been imported or saved, and are available in the Manage Job Configurations dialog can be applied to another migration of the same type. For example, if migrating at the site level, you would not be able to use a job template that is created for a migration at the list level. It would only be able to use a template that migrates at the site level.

The source and target connection types do not apply directly to a job template, so it does not matter if the connection types for the new migration are the same as the connection types for the job template. If the connection types are different than any options that are not applicable for the connection types that are being used will not be available, but all other options will be set.

1.After initiating a migration, click [Open Existing Job Configuration] in the bottom left corner of the Configure <Object> Copying Options dialog to display the Select Job Configuration to Apply dialog.

NOTE:  Any options you have specified directly in the dialog will be overwritten once a job template is applied.

Select Job Configuration to Apply dialog

The  dialog lists all of the job templates that are currently available for the migration type (i.e. a site, list, item, etc. migration), as well as only the templates for the specific Edition of Metalogix Content Matrix that is being used.

2.Select the desired job template and click [OK].

You will be prompted to confirm your action before continuing.  Remember that if you choose to apply the template, any other settings that you entered directly in the Configure <Object> Copying Options  will be lost.

The Configure <Object> Copying Options dialog will now reflect all of the template options. Any additional configuration options can be set or modified, and the migration can continue as normal.

Related Documents