Chat now with support
Chat with Support

Metalogix Archive Manager for Files 8.1.1 - IIS Installation Guide

Installation of IIS for Archive Manager for Files

If HTML shortcuts, VNX Archiving, ArchiveWeb or MS Search features will be used with Archive Manager for Files, IIS with the Active Server Pages is required. The following sections describe step-by-step installation of IIS and additional prerequisites for these operating systems:

·MS Windows Server 2019

·MS Windows Server 2016

·MS Windows Server 2012 R2

·MS Windows Server 2012

·MS Windows Server 2008 R2 SP1

Installation of IIS on MS Windows Server 2012 / 2012 R2 / 2016 / 2019

To install Internet Information Services (IIS):

1.Click Start /Administrative Tools and select Server Manager.

2.Click Manage / Add Roles and Features.

Snap1

 

3.Click Next and Next again. In the Select destination server make sure the Archive Manager server is selected and click Next.

 

Snap2

 

4.Select Web Server (IIS) role. In the pop-up leave the Include management tools check box selected and click Add Features. Then keep clicking Next until the Features dialog.

 

Snap3

 

5.Leave the default features selected plus select the following:

·.NET Framework 3.5 Features

·.NET Framework 4.5 Features / .NET Framework 4.5

·.NET Framework 4.5 Features / ASP.NET 4.5

·.NET Framework 4.5 Features / WCF Services (all checkboxes under this item)

Snap4

6.Click Next twice. On the Roles Services leave the default role services selected, plus select following:

·Web Server / Performance / Dynamic Content Compression

·Web Server / Security / Windows Authentication

·Web Server / Web Server / Application Development / .NET Extensibility 3.5

 / .NET Extensibility 4.5

 / ASP.NET 3.5

 / ASP.NET 4.5

·Web Server / Management Tools / IIS 6 Management Compatibility / IIS 6 Metabase

·Web Server / Management Tools / Management Service

Click Next, then Install.

 

 

Snap5

 

 

Upon installation of Internet Information Services (IIS) you need to enable Web Service Extension ASP.NET v2.0 and ASP.NET v4.0. Follow these steps:

1.Click Start /Administrative Tools /Internet Information Services (IIS) Manager. Select server node and open the ISAPI and CGI Restrictions feature.

Snap6

 

2.Check if ASP.NET v2.0 and ASP.NET v4.0 ISAPI extension is installed and allowed.

 

Snap7

Installation of IIS on MS Windows Server 2008 R2 SP1

 

Let's say your archiving software is running on a MS Windows Server 2008 R2 SP1. Then you need to install Internet Information Services (IIS) and add .NET Framework 3.5 feature. Upon installation of Internet Information Services (IIS) and adding the .NET Framework you need to enable ASP.NET v2.0 and ASP.NET v4.0.

 

 

To install Internet Information Services (IIS):

1.Click Start /Settings /Control Panel /Administrative Tools and select Server Manager.

2.Click on the Roles node. Click on Add Roles link on the right pane.

Snap8

3.Select the Web Server (IIS) role. Click Next.

Snap9

 

4.Leave the default role services selected, plus select following: ASP.NET, Static Content and Windows Authentication. Click Next.

 

Snap10

 

5.Click Install to begin installation of IIS. Finally click on Close to exit.

 

Snap11

 

6.Now in Server manager click Features node -> Add Feature and select .Net Framework 3.5.1 Features / .Net Framework 3.5.1 and click Install.

 

Snap12

 

NOTE: In case of Windows Server 2008R2 SP1 run the following command:

         C:\Windows\Microsoft.NET\Framework\v4.0.30319  aspnet_regiis.exe –i

and then reset the IIS

 In case of Windows Server 2008x64 the path is different:

         C:\Windows\Microsoft.NET\Framework64\v4.0.30319  aspnet_regiis.exe –i

and then reset the IIS

 

 

Upon installation of Internet Information Services (IIS) you need to enable Web Service Extensions ASP.NET v2.0 and ASP.NET v4.0. Follow these steps:

1.Click Start /Settings /Control Panel /Administrative Tools /Internet Information Services (IIS) Manager. Select server node and open the ISAPI and CGI Restrictions feature.

Snap13

2.Check if ASP.NET v2.0 and ASP.NET v4.0 ISAPI extension is installed and allowed.

Snap14

Installation of .NET Framework

Since Archive Manager is built on .NET technology, both .NET Framework 3.5 and 4.5 is required.

You can download .NET Framework 3.5 from the following link:

http://www.microsoft.com/en-us/download/details.aspx?id=21

You can download .NET Framework 4.5 from the following link:

http://www.microsoft.com/en-us/download/details.aspx?id=30653

In case of Windows Server 2008 R2 SP1 it is necessary to download and install only .NET Framework 4.5. The .NET Framework 3.5 has already been added as a feature.

info

NOTE: In case of Windows Server 2008 R2 SP1 run the following command:

C:\Windows\Microsoft.NET\Framework64\v4.0.30319 aspnet_regiis.exe -i

In case of Windows Server 2012/2012 R2/2016/2019 both of them are added via Server Manager.

 

Self Service Tools
Knowledge Base
Notifications & Alerts
Product Support
Software Downloads
Technical Documentation
User Forums
Video Tutorials
Contact Us
Licensing Assistance
Technical Support
View All
Related Documents