Chat now with support
Chat with Support

Metalogix Archive Manager for Exchange 8.1.1 - PST Importer Administration Guide

Importing a .pst file

 

When a file is prepared (the owner, destination folder, as well as password are set) it can be imported and archived.

To import a desired .pst file, simply select it (on the Import tab) and then:

•

Click on the Import selected command on the Import menu; or

•

Right-click it and, in its context menu, select Import selected.

Depending on the result of importing, the respective .pst file will be:

•

removed from the Import tab (and deleted from the Import folder) provided that every item was correctly imported to the destination mailbox and archived, and in case that the Move not archivable messages to mailbox check box is selected each non-archivable item was copied to the destination mailbox as well; or

•

moved to the Processed tab (and moved from the Import folder to the Processed folder) if no 100% importing took place, i.e at least one non-archivable item was found in that .pst file and the Move not archivable messages to mailbox check box was not selected; or

•

moved to the Error tab (and moved from the Import folder to the Error folder) if no 100% archiving took place, i.e. at least one item was not archived due to an error.

It is recommended to check a log file after import (click File/ View logfile, select the log and click Show).

Files (.pst files) can be moved anytime from the Error tab or Processed tab back to the Import tab to modify their settings and retry importing. Simply right-click a desired .pst file displayed on the Error tab or on the Processed tab and then, in its context menu, select Move to import. The file will be moved back to the Import tab.

clip0015

NOTE: After moving a failed import back to the Import folder, the already imported messages are removed from the file. As a result, PST Importer will try to process only the rest of messages.

On the other hand, if the import fails and the user “loads” the original PST file again, then duplicate emails will be imported – those from the first import and those from the second import.

Analyze function

 

The Analyze function is used for obtaining statistical information, but its main purpose is to “track down” the “owner” (in other words the user a .pst file was probably generated by), while considering the results of the analysis.

The built-in Analyze function reads all sender and recipient information from all e-mails contained in that file to produce the statistics. The aim is to facilitate owner assignment. (For detailed information see the section “Analyse tab”.)

Specifying the owner using the Analyze function

To specify the “owner”, run the analysis for a desired .pst file:

1.

On the Import tab select a desired .pst file and then:

 

•

right-click it and in its context menu select Analyze selected; or

 

•

on the Analyze menu select Analyze selected; or

clip0016

 

2.

The Analyse progress window will appear with the overall progress displayed.

NOTE: If the analysis has failed, it is possible that the file is password protected. Right-click the file and select Settings in the context menu. On the Password tab of its PST Properties window enter the password. Click Apply and OK.

1.

The following cases can occur upon completion of the analysis:

 

a)

Provided that a 100% ratio is received as the outcome of the analysis then the “owner” is assigned automatically on condition that the respective mailbox is valid (the mailbox exists and is synchronized with Archive Manager); otherwise the default destination mailbox is assigned (specified under Tools/Options, Default tab) or the one assigned previously manually.

 

b)

When a non-100% ratio is reached (in other words there are at least two users) and the difference between the two highest ratios for valid users (those synchronized with Archive Manager) is higher than the Lowest distinguishing ratio (as specified under Tools/Options, Analyse tab) then the “owner” is assigned automatically, whereas the valid user with the highest ratio is assigned.

 

c)

If a non-100% ratio is reached and there are several valid users meeting the requirement that their respective ratios differ from the highest valid ratio by less than the figure specified as the Lowest distinguishing ratio, then:

 

 

•

if the Take the user who has the most “From” count option is selected then the “owner” is assigned automatically: the valid user with the highest number of From count is assigned. Provided that this figure (From count) is identical for several valid users then the one with the highest ratio is assigned.

 

 

•

if the Take the user who has the most “To” count option is selected then the “owner” is assigned automatically: the valid user with the highest number of To count is assigned. Provided that this figure (To count) is identical for several valid users then the one with the highest ratio is assigned.

 

 

•

if the Always ask option is selected on the Tools/Options/Analyse tab, then the Results of analysis window will be displayed where you will be asked to select the owner.

The left side of the window lists the PST files and the currently assigned user (unknown). When you click on the PST files, the right side displays the list of recipients. Double-click the user you want to select or select the user and click Assign. Once the list is ready, close the window. All PST files will be saved with the changes.

clip0017

 

NOTE: Users displayed with the red cross icon (ADMINI~1_img19) are either not synchronized or non-valid users. You cannot assign the .pst file to them.

When the owner is assigned, either automatically by the Analyze function or by you, the new settings will be displayed also on the Import tab. In our previous example we assigned test1.pst file to Marianne Peters (see below):

clip0018

IMPORTANT NOTE: If no valid user was found for a .pst file by the Analyze function, the default user will be assigned or you can assign user manually (see the section “How to set a specific owner/specific folder”).

How to get summary information about a .pst file

 

Sometimes you may need to know the structure of .pst files, their size, the number of items they contain etc.

Simply select a .pst file, right-click it and in its context menu select Info.

clip0019

 

A pop-up window opens. In the case of password protected files you need to enter the right password first (right-click the respective .pst file, select Settings, then Password tab) to have this window opened.

Summary info includes the size and structure of the respective .pst file. Initially only the folder structure and number of messages are displayed, as shown below.

clip0020

 

After clicking on the Folder size button, their respective sizes are displayed with the total size as well.

clip0021

Log files

 

Each action taken on .pst files is logged in log files. It’s up to the administrator to decide whether those logs would be written into one large log file or each action in a separate log file (see the section “Folders tab”).

To display log files on the File menu select View Logfile.

clip0022

 

A list of log files (the content of the Log folder) will be displayed. This list can be sorted by name, date, or size – simply by clicking on the respective column.

clip0023

 

Either double-click a desired log file or select it and click on the Show button.

Its content will be displayed in the ViewLogFile window.

clip0024

Related Documents