Chat now with support
Chat with Support

InTrust 11.3.1 - System Requirements

Default Set of Components

The components installed by default are InTrust Deployment Manager, InTrust Server and InTrust Repository Viewer. If you customize the selection to install individual components, see the requirements for the components you need. If you use the default selection, the combined requirements are as follows:

Architecture

x64

Operating System

Any of the following:

CPU

Min. 4 cores (for example, for evaluation purposes).

For any real-world uses, at least 8 cores are recommended.

Memory

Min. 4GB (for example, for evaluation purposes).

For any real-world uses, at least 8GB are recommended.*

Additional Software and Services

  • Microsoft .NET Framework 4.5 or later with all the latest updates
  • Microsoft SQL Server Native Client 11.0.6538.0 or later (version 11.0.6538.0 redistributable package of the client is included in the InTrust distribution)
    Important: Install the required version of the client in advance, and only then install InTrust.

* This is only an observation. To estimate consumed memory (in gigabytes) more accurately, use the following formula:

<number_of_cores> * 0.26 + 6

Remember that this means memory used by InTrust Server alone on average. During activity peaks (such as data merging and report building), the memory requirements of InTrust increase.

IMPORTANT: Before you install InTrust, confirm that no unreliable Windows updates are applied. For details about which updates to avoid, see the description of issue IN-1714 in the Release Notes. If your Windows updates are recent, you should be safe.

 

Note: Make sure that the computer where you perform InTrust setup has ports 900, 8340 and 8341 open for inbound traffic and not blocked by any firewalls. This is required for InTrust configuration management, agent–server communication and repository access.

In a virtualized environment

If you deploy InTrust on a virtual machine, make sure the CPU and memory requirements above are met, and do not overload the virtual machine host.

InTrust components can be deployed on virtual machines running in Infrastructure as a Service (IaaS), such as Amazon Web Services and Microsoft Azure.

For the configuration database:

Any of the following:

  • Microsoft SQL Server 2016
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2008 R2

Notes:

  • A local or remote installation of SQL Server can be used.
  • The collation order must be case-insensitive.

Individual Components

The requirements for a custom InTrust deployment vary greatly depending on the components you select. For details, please see the sections about the components you need.

NOTE: If you deploy an InTrust component on a virtual machine, make sure the CPU and memory requirements of the component are met, and do not overload the virtual machine host. InTrust components can be deployed on virtual machines running in Infrastructure as a Service (IaaS), such as Amazon Web Services and Microsoft Azure.

IMPORTANT: Before you install any InTrust components on Windows computers, confirm that no unreliable Windows updates are applied there. For details about which updates to avoid, see the description of issue IN-1714 in the Release Notes. If your Windows updates are recent, you should be safe.

InTrust Deployment Manager

Architecture

  • x64
  • x86 where applicable

Operating System

Any of the following:

Additional Software and Services

  • Microsoft .NET Framework 4.5 or later with all the latest updates
  • Microsoft Visual C++ Redistributable, provided in the Redist folder of your InTrust distribution

InTrust Manager

Architecture

  • x64
  • x86 where applicable

Operating System

Any of the following:

Additional Software and Services

  • Microsoft .NET Framework 4.5 or later with all the latest updates
  • Microsoft Visual C++ Redistributable, provided in the Redist folder of your InTrust distribution

  • Microsoft SQL Server Native Client 11.0.6538.0 or later (version 11.0.6538.0 redistributable package of the client is included in the InTrust distribution)
    Important: Install the required version of the client in advance, and only then install InTrust.
Self Service Tools
Knowledge Base
Notifications & Alerts
Product Support
Software Downloads
Technical Documentation
User Forums
Video Tutorials
Contact Us
Licensing Assistance
Technical Support
View All
Related Documents