Chat now with support
Chat with Support

Foglight 5.7.5 - Upgrade Guide

Understand product versions Best practices Upgrade the Foglight Management Server Upgrade the Foglight Agent Manager Upgrade the Application Monitoring cartridges Upgrade the Database cartridges Upgrade the End User Management cartridges Upgrade the Infrastructure Management cartridges Upgrade the Integration cartridges Upgrade the cartridges in a federated or High Availability (HA) environment Appendix: Deploy an agent package using the browser interface

Upgrade from an Agent Manager version earlier than 5.5.4

If you are upgrading from a version of the Agent Manager that is earlier than 5.5.4, the upgrade may freeze. This can happen if the Agent Manager is running certain older agents that have defects. To resolve this issue, shut down and restart the Agent Manager manually, and then proceed with the upgrade.

If one of these older agents with defects is running in the embedded Agent Manager, the Management Server may freeze during upgrade. Again, if this happens, shut down and restart the Agent Manager manually, and then proceed with the upgrade.

Certificate migration from version 5.6.2.1 or earlier

If you are upgrading from an earlier version than 5.6.2.2, certificates that you manually added to the JRE must be manually migrated to the Agent Manager certificate store after the upgrade. After you manually migrate the certificates during the upgrade from a pre-5.6.2.2 version, no further manual intervention is required for subsequent upgrades.

To perform this one-time migration, you must use the Agent Manager command-line credential tools. With these tools, you can migrate certificates from the JRE certificate store to the Agent Manager’s internal certificate store.

For more information, see the Foglight Command-Line Reference Guide.

 

Upgrade the Application Monitoring cartridges

This section explains how to upgrade an earlier version of an Application Monitoring cartridge to the most current version. For details, refer to these topics:

Upgrade the Application Performance Monitoring cartridges

For details, refer to these topics:

Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating