Chat now with support
Chat with Support

Welcome, erwin customers to Quest Support Portal click here for for frequently asked questions regarding servicing your supported assets.

Foglight 5.7.5 - Upgrade Guide

Understand product versions Best practices Upgrade the Foglight Management Server Upgrade the Foglight Agent Manager Upgrade the Application Monitoring cartridges Upgrade the Database cartridges Upgrade the End User Management cartridges Upgrade the Infrastructure Management cartridges Upgrade the Integration cartridges Upgrade the cartridges in a federated or High Availability (HA) environment Appendix: Deploy an agent package using the browser interface

Upgrade the Foglight Management Server

This section provides information about the following topics:

Migrate to Windows SSO from VSJ SSO

If you were using the VSJ SSO implementation in earlier versions of Foglight, you must migrate to the new Windows OS-based SSO.

1
Make a backup of the vsj.properties file before you upgrade Foglight. You can find this file in the following location:
<foglight_home>/server/default/deploy-foglight/console.war/WEB-INF/vsj.properties
3
If there is no keytab file configured in the VSJ SSO, create the keytab file first using the ktpass command, as described in “Configure Active Directory to support Windows Single Sign-on” section in the Foglight online help.
4
Edit the krb5-auth.config file to set the properties described in the following table.

Principal

Keytab

QualifyUserPrincipal

5
Edit the krb5.config file. Set the realm name to the vsj.properties idm.realm value.

Upgrade the Management Server

NOTE: Ideally, you should create a backup just before performing an upgrade. For more information on creating a backup, see the Foglight Administration and Configuration Help. If you have encounter any problems during the upgrade process, contact Quest Support.

It is important that you see Upgrade a Management Server in a federated environment if you are upgrading the Management Server in a Federated environment.

IMPORTANT: If you want to upgrade the Management Server to version 5.7.5.x from an earlier version, and at the same time upgrade the embedded MySQL® database to the latest version (5.7.16), you must first upgrade the Management Server to version 5.7.1, then to version 5.7.5.x.
Use the Task Manager to verify that the fms.exe process has stopped.
2
If you have customized the Management Server configuration files (such as <foglight_home>/config/server.config, <foglight_home>/config/log.config, or <foglight_home>/server/default/conf/jacorb.properties), back up these files so that you can verify the correct ports are configured after the upgrade is completed. If you have never customized these files, proceed to the next step.
3
Optional: The JRE on disk is replaced completely during a Management Server upgrade. Any existing certificates are retained in $fmshome/jre/lib/security/cacerts.bak.
Known Issue: If you are running an external database, the database upgrade portion of the Management Server upgrade may fail for one of the following reasons:
<foglight_home>\bin\foglight_db_upgrade.[bat|sh]
6
Optional: You can upgrade the currently installed cartridges in one easy step before starting the Management Server. To do this, place the new versions of the cartridges into the folder <foglight_home>/upgrade/cartridge. The cartridges are then installed automatically when the Management Server starts up.
7
If you backed up the configuration files mentioned in Step 2, compare the customizations in these files to determine if they are still necessary. If required, reapply these files before starting the Management Server. Otherwise, skip to Step 9.
<foglight_home>\bin\fms.exe
10
If you upgraded an embedded MySQL® database, you may notice messages such as Starting crash recovery in the log file during startup. These types of messages are benign and can be safely ignored.
11
Log into Foglight through the browser interface by entering http://<yourserver>:<port> in your web browser, where <port> is the applicable port at your location (the default is 8080).

If you encounter any problems while upgrading your Management Server, contact Quest Support for assistance.

For more information, see these topics:

Host services compatibility

A new installation of, or upgrade to, version 5.7.5.8 of the Management Server does not automatically create HostServices for every discovered host. If you want that functionality, install and enable the Service Compatibility Cartridge (<foglight_home>/compat/cartridge/Core-HostServices-Compatibility-5_6_5.car).

If you have already installed and enabled the Service Compatibility Cartridge through a previous upgrade to or after a fresh installation of version 5.5.2, 5.5.4, 5.5.5, or 5.5.8, then the cartridge continues to be active after an upgrade to version 5.7.5.8, and this manual step is not necessary.

Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating